e10s breaks Facebook photo uploader

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: gfritzsche, Assigned: handyman)

Tracking

({regression})

Trunk
x86
Mac OS X
regression
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(e10sm6+)

Details

(Reporter)

Description

2 years ago
* Go to "photos" -> "create album"
* A flash photo uploader should pop up

With async plugin init preffed on, it doesn't appear.
(Reporter)

Updated

2 years ago
Flags: needinfo?(aklotz)
Thanks for the report!
Blocks: 1116806
No longer blocks: 998863
Flags: needinfo?(aklotz)
It works on Windows. I'll reboot into OS X and try it there.
Depends on: 1123916
Georg, can you please retest this now that bug 1123916 has landed?
Flags: needinfo?(gfritzsche)
(Reporter)

Comment 4

2 years ago
Now it's broken independent of async plugin init.
It is working fine in non-e10s windows though.
No longer blocks: 1116806
tracking-e10s: --- → ?
Flags: needinfo?(gfritzsche) → firefox-backlog+
Keywords: regression
Summary: Async plugin init breaks Facebook photo uploader → e10s breaks Facebook photo uploader
Assignee: nobody → davidp99
tracking-e10s: ? → m6+
I can't reproduce this in today's mozilla-central nightly.  I first had to explicitly allow Facebook to "always" launch Flash.  After that I had no problems.  I tested in e10s mode, and with dom.ipc.plugins.asyncInit set to "true" (after restarting).

> * A flash photo uploader should pop up

What, precisely, does this mean?  I saw a native filepicker (presumably from Firefox), entitled "Select file(s) to upload to fbstatic-a.akamaihd.net".  (I didn't actually do anything with the filepicker.  I just canceled out of it.)
I should mention that I tested on OS X 10.8.5, with a non-Retina display.
> I first had to explicitly allow Facebook to "always" launch Flash.

This turns out to be because I'd changed Flash to "always ask".  It doesn't happen with the default setting to "always activate" Flash.
(Reporter)

Comment 8

2 years ago
(In reply to Steven Michaud from comment #5)
> I can't reproduce this in today's mozilla-central nightly.  I first had to
> explicitly allow Facebook to "always" launch Flash.  After that I had no
> problems.  I tested in e10s mode, and with dom.ipc.plugins.asyncInit set to
> "true" (after restarting).
> 
> > * A flash photo uploader should pop up
> 
> What, precisely, does this mean?  I saw a native filepicker (presumably from
> Firefox), entitled "Select file(s) to upload to fbstatic-a.akamaihd.net". 
> (I didn't actually do anything with the filepicker.  I just canceled out of
> it.)

Indeed, thats the Flash filepicker i mean (it is visibly from Flash and not natively from Firefox on retina because its low DPI on the high DPI screen).
It seems to have started working in the last two or three weeks then, so closing WFM.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Comment 9

2 years ago
Plugin still crashes for me on 40.0a2 (2015-05-25)build.
You need to log in before you can comment on or make changes to this bug.