Closed Bug 1125230 Opened 6 years ago Closed 6 years ago

[UX] Create specs for V1 of control center

Categories

(Firefox :: General, defect)

38 Branch
defect
Not set
normal
Points:
8

Tracking

()

RESOLVED FIXED
Iteration:
39.1 - 9 Mar

People

(Reporter: phlsa, Assigned: phlsa)

References

Details

(Whiteboard: [ux])

Attachments

(1 file, 2 obsolete files)

Iterating on the work coming out of bug 1119786, we need to define all the states we think would be useful for a V1 of control center.

Objectives of this bug:
- Enumerate and mock up the states for V1
- Explore enough of the scenarios beyond V1 to make sure we're not blocking future development with the short-term work.
Flags: firefox-backlog+
Flags: qe-verify-
Blocks: 1125402
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Iteration: --- → 38.2 - 9 Feb
Points: --- → 8
Iteration: 38.2 - 9 Feb → 38.3 - 23 Feb
This is still not complete, but I'd like to get some broader feedback at that point.
Here's the latest version: http://invis.io/GD2739CRH

Flagging a few people for feedback – feel free to comment either here or directly in Invision.
Flags: needinfo?(agrigas)
commented on the invision
Flags: needinfo?(agrigas)
Commented in invision. It's pretty nice!
Flags: needinfo?(mmc)
Iteration: 38.3 - 23 Feb → 39.1 - 9 Mar
Attached image Control Center v1 (wireframe spec) (obsolete) —
Here's the (hopefully) final spec for Control Center v1. It is also on Invision for easier commenting: http://invis.io/T92BBH3FC

Please note that these comps are wireframe quality (so stylistic changes are still possible), but I think we're good in terms of structure and strings.
Attachment #8569784 - Flags: ui-review?(shorlander)
Attachment #8569784 - Flags: feedback?(mmc)
Nice mock up Philipp!

Will this new design be in addition to the shield icon or used instead of the shield icon?

For Mixed Content Blocker, you probably need a mock up for the case where there is both mixed active content and mixed passive content on the page that says something like "Some insecure elements on this page have been blocked":
https://people.mozilla.org/~tvyas/mixedboth.html

And here are a couple more test pages in case they are useful when looking at the current behavior:
https://people.mozilla.org/~tvyas/mixedcontent.html - contains mixed active content only
https://people.mozilla.org/~tvyas/mixeddisplay.html - contains mixed display content only

For an HTTP page, the mockups use the word "unencrypted" but for mixed content they use the word "insecure".  Is this intentional? Perhaps we should use the same word in both places.

The text for when MCB is disabled says "blocked" when you may have meant to change that to "unblocked" or "allowed".  The current text for this case says: 
This website contains interactive content that isn't encrypted (such as scripts). Other people can view your information or modify the website's behavior.
(In reply to Tanvi Vyas [:tanvi] from comment #5)
> Nice mock up Philipp!
> 
> Will this new design be in addition to the shield icon or used instead of
> the shield icon?
> 
> For Mixed Content Blocker, you probably need a mock up for the case where
> there is both mixed active content and mixed passive content on the page
> that says something like "Some insecure elements on this page have been
> blocked":
> https://people.mozilla.org/~tvyas/mixedboth.html
> 
> And here are a couple more test pages in case they are useful when looking
> at the current behavior:
> https://people.mozilla.org/~tvyas/mixedcontent.html - contains mixed active
> content only
> https://people.mozilla.org/~tvyas/mixeddisplay.html - contains mixed display
> content only
> 
> For an HTTP page, the mockups use the word "unencrypted" but for mixed
> content they use the word "insecure".  Is this intentional? Perhaps we
> should use the same word in both places.
> 
> The text for when MCB is disabled says "blocked" when you may have meant to
> change that to "unblocked" or "allowed".  The current text for this case
> says: 
> This website contains interactive content that isn't encrypted (such as
> scripts). Other people can view your information or modify the website's
> behavior.

Philipps offline but I'm working with him on polaris work so I can answer some of your questions - the shield is replaced for mixed content and will instead be used to represent when tracking protection is enabled.
(In reply to agrigas from comment #6)
> Philipps offline but I'm working with him on polaris work so I can answer
> some of your questions - the shield is replaced for mixed content and will
> instead be used to represent when tracking protection is enabled.

The shield icon has been associated with Mixed Content Blocker since it was released in 2013, so removing it from mixed content might cause confusion.  Since Tracking Protection is a relatively new feature that currently has a limited number of users, what if we create a new icon for it?

Also, in the proposed flow, how will the user know that mixed content is being blocked on a page without the shield doorhanger?  Currently the doorhanger is a signal that their is content being blocked on the page.  Without a doorhanger, the page looks like any other SSL page with a lock icon.  If it is not functioning properly, the user won't know to click on the lock icon and disable protection.
Or perhaps the proposal is that the shield be used in Control Center for Tracking Protection, but that the shield doorhanger continues to behave the same way it currently does (for both Mixed Content Blocker and Tracking Protection).  That would work.
I'll let philipp answer that as he's more familiar with that piece of the design.
There has btw been some discussion about the emphasis we seem to be planning to put on EV certs here:

https://twitter.com/dveditz/status/571942983014068224
Flags: needinfo?(ttaubert)
Hardware: x86 → All
Comment on attachment 8569784 [details]
Control Center v1 (wireframe spec)

Commented on invision.
Attachment #8569784 - Flags: feedback?(mmc)
Attached image updated control center TP.png (obsolete) —
updated wireframe spec that create more consistency in use of tp shield icon when enabled and disabled and consistently shows tracker count
Attachment #8569784 - Attachment is obsolete: true
Attachment #8569784 - Flags: ui-review?(shorlander)
Do we need a visual design bug here to be added to backlog for 39.2 starting Tuesday?
Flags: needinfo?(philipp)
Flags: needinfo?(agrigas)
I believe Philipp created one already. Ping him when you can to verify.
Flags: needinfo?(agrigas)
Updated some copy in the wireframe and removed inconsistencies.
Attachment #8571553 - Attachment is obsolete: true
I filed bug 1140774 for the visual design.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(philipp)
Resolution: --- → FIXED
Duplicate of this bug: 1066437
Duplicate of this bug: 1107654
Hey Ash, re this comment from https://mana.mozilla.org/wiki/display/FIREFOX/Polaris+Tracking+Protection+and+Control+Center+UX

"Five tracking elements detected. Protection is disabled for this site."

It is not a good idea to give the user a count of elements that have been detected but not blocked. For example, on weather.com, blocking 4 elements prevents another 40-odd domains from loading, many of which are tracking elements. So the flow would be

1) "40 tracking elements detected. Protection is disabled for this site"
2) Users enable tracking protection
3) "5 tracking elements blocked"

which is a very confusing message to have to explain to users. IMO, revealing the number of detected elements is not worth it. Francois, please follow up with Ash and Philipp about this.

Thanks,
Monica
Flags: needinfo?(francois)
Flags: needinfo?(agrigas)
I agree with Monica, I would suggest:

- changing "(5) Five tracking elements detected." to "Tracking elements detected."
- keeping "(5) Five attempts to track your online behavior have been blocked." as it is
Flags: needinfo?(francois)
(In reply to François Marier [:francois] from comment #20)
> I agree with Monica, I would suggest:
> 
> - changing "(5) Five tracking elements detected." to "Tracking elements
> detected."
> - keeping "(5) Five attempts to track your online behavior have been
> blocked." as it is

That is fine with me. Sorry I was late to the thread - copy still hasn't been finalized as this feature now is on pause. I will update the wiki for when we get to that point and have a timeline for release.
Flags: needinfo?(agrigas)
(In reply to [:mmc] Monica Chew (no longer reading bugmail) from comment #19)
> Hey Ash, re this comment from
> https://mana.mozilla.org/wiki/display/FIREFOX/
> Polaris+Tracking+Protection+and+Control+Center+UX
> 
> "Five tracking elements detected. Protection is disabled for this site."
> 
> It is not a good idea to give the user a count of elements that have been
> detected but not blocked. For example, on weather.com, blocking 4 elements
> prevents another 40-odd domains from loading, many of which are tracking
> elements. So the flow would be
> 
> 1) "40 tracking elements detected. Protection is disabled for this site"
> 2) Users enable tracking protection
> 3) "5 tracking elements blocked"
> 
> which is a very confusing message to have to explain to users. IMO,
> revealing the number of detected elements is not worth it. Francois, please
> follow up with Ash and Philipp about this.
> 
> Thanks,
> Monica

Monica - anything you want noted/captured before you leave you can add as a comment on the wiki since this bug is closed: https://mana.mozilla.org/wiki/display/FIREFOX/Polaris+Tracking+Protection+and+Control+Center+UX
I'd like to make one suggestion please:
the 
> (5) Five tracking elements detected
> (5) Five attempts to track you
to be dash-underlined, 
and whenever you mouseover them,
to display in a popup the URLs that have been blocked.
(In reply to Kostas from comment #23)
> I'd like to make one suggestion please:
> the 
> > (5) Five tracking elements detected
> > (5) Five attempts to track you
> to be dash-underlined, 
> and whenever you mouseover them,
> to display in a popup the URLs that have been blocked.

Thanks for the suggestion but we have already defined this UI for this ticket. We can incorporate this feedback for future iterations.
Mistakenly filed against Firefox 38 and should be instead 38 Branch. Sorry for the spam. dkl
Version: Firefox 38 → 38 Branch
You need to log in before you can comment on or make changes to this bug.