[FLATFISH]Calendar "Some thing is wrong, try again later." message appears when editing full day event.

RESOLVED DUPLICATE of bug 1117713

Status

Firefox OS
Gaia::Calendar
RESOLVED DUPLICATE of bug 1117713
3 years ago
3 years ago

People

(Reporter: Ravi, Unassigned)

Tracking

({regression})

unspecified
regression

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.2 unaffected, b2g-master affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.91 Safari/537.36

Steps to reproduce:

OS Version: 2.2.0.0-prerelease
Firmware revision : flatfish_20141223-0139
Platform version: 34.0a1
Build ID: 20141223015904

Steps to reproduce:
1. Create a full day event in calendar.
2. Save it.
3. Edit the same event.
4. Disable Full day Event.
5. Do not modify time, use the default values i.e 12:00 AM to 12:00 AM and save.


Actual results:

Error Message "Something is wrong, Try again later." appears at the bottom.


Expected results:

At least it should specifically say what went wrong.
(Reporter)

Updated

3 years ago
Summary: [FLATFISH]Calendar "Some thing is wrong, try again later." message → [FLATFISH]Calendar "Some thing is wrong, try again later." message appears when editing full day event.
Here is a video of the issue occuring: http://youtu.be/jBkyVMpwfoM
A logcat is attached as well

This issue is still occuring on Flame 3.0

The user will see an error saying "Something went wrong, try again later" because the date was not updated to end on the next day

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150128010234
Gaia: 1d53fb07984298253aad64bfa4236b7167ee3d4d
Gecko: b2b10231606b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
________________________________________________________________________

This issue is NOT occuring on Flame 2.2

The date is updated properly to the next day and no error is hit

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150127002504
Gaia: 80d5b797fd0497a7e3337b7798a21b2e1219681a
Gecko: 01bf1516a65b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: UNCONFIRMED → NEW
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Ever confirmed: true
Flags: needinfo?(pbylenga)
Keywords: regression
Component: General → Gaia::Calendar
[Blocking Requested - why for this release]:
Functional regression of a core feature.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Contact: ychung
QA Contact: ychung
Duplicate of this bug: 1117713
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1117713
Keywords: regressionwindow-wanted
blocking-b2g: 3.0? → -
You need to log in before you can comment on or make changes to this bug.