Overflow of contact name while tapping on the recepient in composer

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::SMS
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: rishav_, Assigned: ashutosh.nath.agarwal, Mentored)

Tracking

({regression})

unspecified
2.2 S5 (6feb)
x86_64
Linux
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, tracking-b2g:backlog, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8554181 [details]
2015-01-19-19-15-53.png

STR:
1.Go to compose.
2.Add recepient (whose name is long i.e length>40)
3.Now tap on the recepient.
4.check in Confirm window: recepient name over flow.
(Reporter)

Comment 1

4 years ago
Created attachment 8554182 [details]
2015-01-19-19-15-36.png
Created attachment 8554185 [details] [review]
[PullReq] ash7594:Bug1125525 to mozilla-b2g:master
(Reporter)

Updated

4 years ago
Assignee: nobody → ashutosh.nath.agarwal
(Reporter)

Updated

4 years ago
Attachment #8554185 - Flags: review?(azasypkin)
I think it's better do put this change in the Building Blocks.
Blocks: 1105857
Bug 1105857 is in v2.2 and v2.0m, I think we should fix in both branches.
blocking-b2g: --- → 2.2?
(Assignee)

Comment 5

4 years ago
Hi. I'm a new contributor. I will fix it in the shared css (building blocks).
What should I do to fix in both batches - v2.2 and v2.0
Flags: needinfo?(felash)
(Assignee)

Comment 6

4 years ago
Hi. I have fixed the bug in building blocks. Kindly guide me for the other branch. Thanks
(In reply to ashutosh.nath.agarwal from comment #6)
> Hi. I have fixed the bug in building blocks. Kindly guide me for the other
> branch. Thanks

I think it will be made automatically from your patch to master.
Flags: needinfo?(felash)
Comment on attachment 8554185 [details] [review]
[PullReq] ash7594:Bug1125525 to mozilla-b2g:master

Per GitHub looks like Julien is already reviewing/reviewed this patch, redirecting to him :) 

Ashutosh, please don't forget to ask for review from Pavel Ivanov (:ivanovpavel) as well as it's BB change that will affect a big chunk of applications.
Attachment #8554185 - Flags: review?(azasypkin) → review?(felash)
(In reply to Julien Wajsberg [:julienw] from comment #4)
> Bug 1105857 is in v2.2 and v2.0m, I think we should fix in both branches.

As far as I remember v2.2 and v2.0m patches have a bunch of differences especially related to styling. So having said that I can't repro this issue on v2.0m - name is automatically broken into several lines there.
(Reporter)

Updated

4 years ago
Attachment #8554185 - Flags: review?(pivanov)
Comment on attachment 8554185 [details] [review]
[PullReq] ash7594:Bug1125525 to mozilla-b2g:master

LGTM r+ and thanks :)
Attachment #8554185 - Flags: review?(pivanov) → review+
triage: non-blocking but nice to have it fixed. please ask for approval to uplift.
blocking-b2g: 2.2? → backlog
Comment on attachment 8554185 [details] [review]
[PullReq] ash7594:Bug1125525 to mozilla-b2g:master

r=me
Attachment #8554185 - Flags: review?(felash) → review+
I restarted the failing tests just to be sure they're intermittent. Please don't add checkin-needed until they finish.
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/27652

The pull request could not be applied to the integration branch. Please try again after current integration is complete.
master: 229efc18377cd203be97d92995175c08e06307ad
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

4 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/27652

The pull request could not be applied to the integration branch. Please try again after current integration is complete.
(Assignee)

Comment 17

4 years ago
Thank you :)
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
Mentor: felash
Duplicate of this bug: 1150793
Keywords: regression
Comment on attachment 8554185 [details] [review]
[PullReq] ash7594:Bug1125525 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Don't know
[User impact] if declined: See attachment 8587820 [details]
[Testing completed]: yes, it's in master since January.
[Risk to taking this patch] (and alternatives if risky): very low, one-line CSS change that does not change layout.
[String changes made]: none
Attachment #8554185 - Flags: approval-gaia-v2.2?
triage: the triage meeting decided to fix.
blocking-b2g: --- → 2.2+
Dear triagers, look at comment 11 :)
(does it mean we have a broken process?)
No, sorry for not making it clear.
We re-triaged this because this is a duplicate to bug 150793 being nominated.
The decision made today is based on below reasons:
1. it's a regression which has impact on the usability. 
2. there's already a fix
3. risk is very low
4. we need blocking status to uplift
Please nominate this patch for Gaia v2.2 approval when you get a chance.
status-b2g-v2.2: --- → affected
status-b2g-master: --- → fixed
Flags: needinfo?(ashutosh.nath.agarwal)
Target Milestone: --- → 2.2 S5 (6feb)
Already done.
Flags: needinfo?(ashutosh.nath.agarwal)

Updated

3 years ago
Attachment #8554185 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on the latest 3.0 and 2.2 Nightly Flame builds.

Actual Results: Overly long contact names are wrapped and do not go off screen

Environmental Variables:
Device: Flame 3.0 KK (319 MB) (Full Flash)
BuildID: 20150604010200
Gaia: 9e10483c5808f94f4a0a9f6afe30aae2c5b42b4c
Gecko: 98820360ab66
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Environmental Variables:
Device: Flame 2.2 KK (319 MB) (Full Flash)
BuildID: 20150604002503
Gaia: b96e657ce2822df5da5da1a8ba91c38ad3281bc9
Gecko: 273f8ee45c88
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.