Closed Bug 1125545 Opened 5 years ago Closed 4 years ago

[Homescreen] The threshold distance for clicking an icon vs. scrolling is too large.

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: mcav, Unassigned)

References

Details

You can drag your finger across at least half an icon-width before the homescreen decides that you intended to scroll rather than open an app. This threshold should be much smaller; its current value makes the homescreen seem much laggier than it is.

STR:

1. Touch down on the homescreen.
2. Drag to scroll; you can drag very far without the screen beginning to scroll.

I'm assuming that this dead-zone is to differentiate between clicks. If so, I'd like to suggest an alternate algorithm, which seems more in line with Android/iOS:

1. Always scroll immediately upon receiving mouse events, so that the user
   percieves touch response as instant.
2. Differentiate with an algorithm like the following:
   a) If the scroll distance exceeds a threshold, it was not a click.
   b) If we receive a touchend with a sufficiently small scroll distance,
      stop the scroll and treat it as a click (or hold depending on time).

The lagginess is also related to bug 1125544, in which the "dead zone" doesn't contribute to the scroll distance, increasing the perception of lag. That bug would be obsoleted by this one, if implemented.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120859
Unduping per in-person discussion.
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: DUPLICATE → ---
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.