bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

message pane doesn't show focus ring

VERIFIED FIXED in mozilla0.9.8

Status

SeaMonkey
MailNews: Message Display
--
trivial
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: Joe Hewitt (gone))

Tracking

({regression})

Trunk
mozilla0.9.8
x86
Windows 95
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
For some reason when I click on the message pane the focus ring doesn't appear,
possibly because the commandDispatcher is returning null for the focusedElement.
(Reporter)

Comment 1

17 years ago
Created attachment 59674 [details] [diff] [review]
Proposed patch
(Reporter)

Updated

17 years ago
Keywords: patch, regression, review

Updated

17 years ago
Attachment #59674 - Flags: review+
(Reporter)

Comment 2

17 years ago
CCing bryner because shaver tells me he knows about the command dispatcher.

Comment 3

17 years ago
I think there's already a bug on this.
QA Contact: esther → olgam

Comment 4

17 years ago
We need more details when there is no focus in Thread pane.
There are dif bugs regarding this.
(Reporter)

Comment 5

17 years ago
*** Bug 112749 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
From duplicate I see "the message display window".
You refer to "message pane". It looks like that you both talk about Message Body
area. It's covered in bug 109193: Focus ring is only in the Thread pane, not in
Folder or Message Body pane. Do you mind if I mark it as duplicate as well?
(Reporter)

Comment 7

17 years ago
I have no problems with the focus in the folder pane, so it could be mac-specific.

Comment 8

17 years ago
May we clarify the issue here? Now you say "no problems with the focus in the
folder pane". Also why Mac, bug shows Win 95.
I was talking about the message body area.

Comment 10

17 years ago
Thanks for raising the issue!

*** This bug has been marked as a duplicate of 109193 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 11

17 years ago
Verified dup.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 12

17 years ago
Firstly, you shouldn't resolve and verify the same bug.
Secondly, my original point is that this report only applies to the message body
area, not to the Mac folder pane. My Windows folder pane focuses perfectly.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 13

17 years ago
this one has been bothering me too
Assignee: sspitzer → hewitt
Status: REOPENED → NEW
Target Milestone: --- → mozilla0.9.8
(Assignee)

Comment 14

17 years ago
Created attachment 61006 [details] [diff] [review]
patch

This patch does a bit more than neil's earlier patch.  It cleans up some
incredibly ugly code in FocusRingUpdate_Mail and does a more explicit check to
see if the message pane is focused.
(Reporter)

Comment 15

17 years ago
Comment on attachment 61006 [details] [diff] [review]
patch

I don't understand:
1. Why do you check the current focused element is the thread outliner, folder
outliner or message pane before setting the focus ring, becuase it must always
be one of the three. Or, you could just check for the message pane and use
:focus rules for the thread and folder panes.
2. Why don't you check for the message pane. If the attachment tree has the
focus then WhichPaneHasFocus should return the message pane.
3. focusedWindow looks like a cheap operation so it should be done first.
(Assignee)

Comment 16

17 years ago
Alas, there is one other thing in the mail window that can get focus: the
sidebar, which is why I check if each of the three panes has the focus.
Status: NEW → ASSIGNED

Comment 17

17 years ago
Updating multiple bugs. This is a valid UI issue. Would be nice to have it fixed
if time allows.
(Reporter)

Comment 18

17 years ago
if (!currentFocusedElement)
     return;

takes care of the sidebar, because it is never returned from WhichPaneHasFocus().

See also the combined patch attached to bug 102711.
(Assignee)

Comment 19

17 years ago
fix checked in, updated after comments from neil
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 20

17 years ago
var gSearchInput; missing from msgMail3PaneWindow.js (patch is in bug 102711).
(Assignee)

Comment 21

17 years ago
thanks neil, just checked in that line

Comment 22

17 years ago
Verified on today's and yesterday build 2002-01-03.
Win 2K, Linux, Mac OSX.
Status: RESOLVED → VERIFIED

Comment 23

17 years ago
*** Bug 109193 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.