Closed Bug 1125784 Opened 6 years ago Closed 6 years ago

Remove JS_ConvertArguments

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla38
Tracking Status
firefox38 --- fixed

People

(Reporter: jandem, Assigned: jandem)

References

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

Attached patch PatchSplinter Review
JS_ConvertArguments is unsafer (varargs) and slower than CallArgs + calling the conversion functions manually.

This patch fixes the handful of places (mostly shell/test functions) that still used it and removes it.

I also removed JS_ConvertValue, it's not used anywhere (and looks like it doesn't work for symbols).
Attachment #8554489 - Flags: review?(jorendorff)
Attachment #8554489 - Flags: review?(jorendorff) → review+
Duplicate of this bug: 505903
https://hg.mozilla.org/mozilla-central/rev/0ae3113e0583
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
You need to log in before you can comment on or make changes to this bug.