Closed Bug 505903 Opened 11 years ago Closed 5 years ago

jsshell/xpcshell Quit should check return value from JS_ConvertArguments

Categories

(Core :: JavaScript Engine, defect, minor)

defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 1125784

People

(Reporter: timeless, Assigned: timeless)

References

(Blocks 1 open bug, )

Details

(Keywords: coverity)

# js/src/shell/js.cpp (View Hg log or Hg annotations)
    * line 1032 -- JS_ConvertArguments(cx, argc, argv,"/ i", &gExitCode); 
# js/src/xpconnect/shell/xpcshell.cpp (View Hg log or Hg annotations)
    * line 501 -- JS_ConvertArguments(cx, argc, argv,"/ i", &gExitCode); 

Are the only places that don't.
Bug 1125784 replaced JS_ConvertArguments with a ToInt32 call and we check the return value now.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1125784
You need to log in before you can comment on or make changes to this bug.