[Wallpaper][Text Selection] Long pressing a wallpaper selects them all and causes the blue text selection carets/bubbles to appear when selecting a wallpaper.

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: pdahiya)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], )

Attachments

(3 attachments)

Reporter

Description

4 years ago
Description:
When in the gallery of wallpapers, if you long-press on one, they all become selected. A blue text selection caret will appear that you can manipulate/move around to change the selection box surrounding all the wallpapers. This issue is visual only, no functionality seems to be broken with this and 

Repro Steps:
1) Update a Flame to 20150126010231
2) Long press on an open area of the homescreen 
3) Select Change Wallpaper
4) Select Wallpaper
5) Long press on a wallpaper selection

Actual:
All wallpapers are selected - blue caret appears below 1st box / picture

Expected:
Text Selection functionality will not be present in the wallpaper picker. Long press will not have any function / will not select all

Environmental Variables:
Device: Flame 3.0 (KK - Nightly - OTA)
Build ID: 20150126010231
Gaia: 0f662dffef27599443cfcd790c2b39190a2b35c8
Gecko: fa91879c8428
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Repro frequency: 6/6
See attached: logcat, video: http://youtu.be/Qp8yS_Lhe4A

-------------------------------------------------------------------------------------

This issue also reproduces in Flame 2.2 (KK - nightly - full flashed)
Text Selection was introduced in 2.2 so this issue is not (would not be present) in 2.1 or earlier

Device: Flame 2.2 (KK - Nightly - Full Flash)
Build ID: 20150122002808
Gaia: e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gecko: 4a90da67661e
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Reporter

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
I can also recreate this issue. CC developers for investigation.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][textselection]
Flags: needinfo?(gchang)
Attach the image of showing carets in wallpaper.

Comment 4

4 years ago
broken new feature nominated as 2.2?
Blocks: CopyPasteGaia
No longer blocks: CopyPasteLegacy
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage+][textselection] → [QAnalyst-Triage+][COM=Text Selection]

Comment 5

4 years ago
AFAIK, there were no text selection changes (including disabling it) done for wallpaper. It was not in the prioritized list for 2.2 text selection bugs. Why is this nominated as broken feature blocker -- there is no functionality broken for wallpaper as stated in the original description.

Punam, 

Take a look at it after any 2.2 blockers that you can help fix. 

Thanks
Hema
Flags: needinfo?(pdahiya)
Flags: needinfo?(hochang)

Comment 6

4 years ago
Hi Hema, 

You are right...I just check the Gaia 2.2 copy paste work bug 1092944 and wallpaper wasn't there, it actually should be but I missed it, sorry about that.

Still, I'd say this bug should be fixed since the caret showing isn't expected behavior.

Thank you all for the help.
Flags: needinfo?(hochang)
Assignee

Updated

4 years ago
Assignee: nobody → pdahiya
Flags: needinfo?(pdahiya)
Assignee

Comment 8

4 years ago
Comment on attachment 8560626 [details] [review]
[PullReq] punamdahiya:Bug1126022 to mozilla-b2g:master

Hi David
Please review attached patch which by default disables user text selection for wallpaper app. Thanks!
Attachment #8560626 - Flags: review?(dflanagan)
Comment on attachment 8560626 [details] [review]
[PullReq] punamdahiya:Bug1126022 to mozilla-b2g:master

Looks good to me, though I did not test it.
Please nominate for 2.2 uplift once you have landed this.
Attachment #8560626 - Flags: review?(dflanagan) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 11

4 years ago
Comment on attachment 8560626 [details] [review]
[PullReq] punamdahiya:Bug1126022 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Not a Regression
[User impact] if declined: Long press on one of the wallpaper selects all the wallpapers.
[Testing completed]:On master
[Risk to taking this patch] (and alternatives if risky): Very low
[String changes made]: None
Attachment #8560626 - Flags: approval-gaia-v2.2?(bbajaj)
blocking-b2g: 2.2? → 2.2+
Attachment #8560626 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed on Flame Master and 2.2.

Result: Long pressing on a wallpaper does not have any function. 
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150319010201
Gaia: c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gecko: cf1060d8ce9f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150319002500
Gaia: 9043c11f699c15bb6072422d1dad6518d1b5ddda
Gecko: c0442d170bec
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][COM=Text Selection] → [QAnalyst-Triage?][COM=Text Selection]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][COM=Text Selection] → [QAnalyst-Triage+][COM=Text Selection]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.