Don't use SQLite tracing unless the right environment variable is set

RESOLVED DUPLICATE of bug 1126129

Status

()

Toolkit
Storage
RESOLVED DUPLICATE of bug 1126129
3 years ago
3 years ago

People

(Reporter: Ben Turner (not reading bugmail, use the needinfo flag!), Assigned: Ben Turner (not reading bugmail, use the needinfo flag!))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Bug 806819 defined FORCE_PR_LOG everywhere, and the storage code then uses SQLite's tracing API regardless of whether or not the user wants to see those messages. This can slow us down significantly.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1126129
You need to log in before you can comment on or make changes to this bug.