[Text Selection] Utility bubble shows when long pressing on list item in privacy panel

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: gchang, Assigned: kaze)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(4 attachments)

### Steps:
1. Open Settings app
2. Navigate to Privacy Panel
3. Long press on any character of "Location Accuracy" or "Remote Privacy Protection" or "Transparency Control" or "Guided Tour"

### Expected:
1. The behavior should be consistent with other list items in settings

### Actual:
1. The word is selected and utility bubble shows

### Reproduce rate
always

### Version:
Gaia-Rev        cc88f3c3ffaef71a15f34e16e5cc17f289683dcc
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/db9a9e77ebea
Build-ID        20150126162505
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
QA Whiteboard: [textselection]
Also found that most items in Privacy Panel can be selected including list items, header, and buttons.
Please see the attachment.
broken new feature nominated as 2.2?
Blocks: CopyPasteGaia
No longer blocks: CopyPasteLegacy
blocking-b2g: --- → 2.2?
Whiteboard: [systemsfe]
Whiteboard: [systemsfe]
QA Whiteboard: [textselection] → [COM=Text Selection]
Taking, this looks like a missing CSS rule.
Assignee: nobody → fabien
Posted file pull request
Attachment #8560204 - Flags: review?(etienne)
Comment on attachment 8560204 [details] [review]
pull request

lgtm!
Attachment #8560204 - Flags: review?(etienne) → review+
Merged on master: https://github.com/mozilla-b2g/gaia/commit/eb91f95
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8560204 [details] [review]
pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): copy/paste support
[User impact] if declined: panning can trigger the text utility bubble
[Testing completed]: manual
[Risk to taking this patch] (and alternatives if risky): none (CSS only)
[String changes made]: none
Attachment #8560204 - Flags: approval-gaia-v2.2?(bbajaj)
blocking-b2g: 2.2? → 2.2+
Attachment #8560204 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed on the lates Nightly Flame 3.0 build.

Actual Results: The user cannot text select the menu items or the text of the guided tour in Privacy Panel.

Environmental Variables:
Device: Flame 3.0 KK (Full Flash) (319 MB)
BuildID: 20150316010202
Gaia: 4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
Gecko: 436686833af0
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Text Selection] → [QAnalyst-Triage?][COM=Text Selection]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][COM=Text Selection] → [QAnalyst-Triage+][COM=Text Selection]
Flags: needinfo?(ktucker)
Keywords: verifyme
This bug has been successfully verified on latest Flame v2.2.
See attachment: verified_v2.2.MP4
Reproduce rate: 0/5

STR:
1.Open Settings app.
2.Navigate to "Privacy Controls".
3.Long press on any character:"Next","Location Accuracy","Remote Privacy Protection","Transparency Control" or "Guided Tour".
**User can't enter text selecting mode on the menu items or the text of the guided tour in "Privacy Controls".

Flame 2.2 (Pass):
Build ID               20150316162504
Gaia Revision          d0e09d5e6367e558824f9cbf691da99cedf63037
Gaia Date              2015-03-16 17:14:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/793d61bb0bd4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150316.195035
Firmware Date          Mon Mar 16 19:50:48 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+][COM=Text Selection] → [QAnalyst-Triage+][COM=Text Selection][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.