[RTL][Homescreen]The confirm information is not right-aligned when deleting apps from the homescreen.

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: gmarty)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(5 attachments)

Reporter

Description

4 years ago
Posted image deleteapps.png
[1.Description]:
[RTL][Homescreen]When you long press an app at homescreen and delete it, the confirm information is not right-aligned.
See attachment:deleteapps.png

[2.Testing Steps]: 
Prerequisite: Set system language as Arabic.
1. Long press an app at homescreen.
2. Tap the "x" button to delete a app.(Such as Marketplace)

[3.Expected Result]: 
2. The confirm information should be right-aligned.

[4.Actual Result]: 
2. The confirm information is left-aligned.

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        0518f4581a0925c0b703d730ef289ab15cbd1216
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c6aa604a7967
Build-ID        20150126002536
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150126.042138
FW-Date         Mon Jan 26 04:21:49 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
The delete button and cancel button are not mirrored when deleting the SmartCollections.
See attachment:deleteSmartCollections.png
Reporter

Comment 1

4 years ago
Priority: -- → P2

Updated

4 years ago
feature-b2g: --- → 2.2+
Whiteboard: [systemsfe]
Assignee: nobody → gmarty
Assignee

Comment 2

4 years ago
Posted file Github PR
Kevin, can you have a look?
Attachment #8557042 - Flags: review?(kgrandon)
Comment on attachment 8557042 [details] [review]
Github PR

This looks good. This does only fix the smart collections confirm screen, and not the uninstall app one. I believe the uninstall app one lives in the system somewhere.
Attachment #8557042 - Flags: review?(kgrandon) → review+
Reporter

Comment 4

4 years ago
Posted image confirm.png
When delete app from App Permissions, the confirm message is left-aligned and Delete, Cancel buttons are not mirrored.
Repro Steps:
1. Set system language as Arabic.
2. Launch Settings -> App Permissions.
3. Select Geoloc and tap Uninstall App button.
**The confirm message is left-aligned and Delete, Cancel buttons are not mirrored.
See attachment:confirm.png
Rate:5/5

Flame 2.2 build:
Build ID               20150203002504
Gaia Revision          cd62ff9fe199fb43920ba27bd5fdbc5c311016fc
Gaia Date              2015-02-03 00:56:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/11d93135c678
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150203.041704
Firmware Date          Tue Feb  3 04:17:15 EST 2015
Bootloader             L1TC000118D0
Sue: not sure why you verified this bug again. It didn't land anywhere yet!
Reporter

Comment 6

4 years ago
(In reply to Delphine Lebédel [:delphine - use need info] from comment #5)
> Sue: not sure why you verified this bug again. It didn't land anywhere yet!

Hi Delphine,
This case that was mentioned on comment 4 was found on free test. And according to comment 3, to make sure all cases are covered, I add this case to this bug for your further reference.
Guillaume, does it make sense to fix the bug mentioned in comment 4 here, or should we file a new bug?
Flags: needinfo?(gmarty)
Reporter

Comment 8

4 years ago
Update the result info of step 3 in comment 4. The buttons are mirrored, but confirm message is not right-aligned.

Updated

4 years ago
See Also: → system-dialog-rtl
Blocks: system-rtl
No longer blocks: system-dialog-rtl
Assignee

Comment 9

4 years ago
Hey Kevin, I double-checked and it seems that this PR fixes both dialog as they're based on <gaia-confirm> even though they're not using the same markup.

I'll land it for now and we can always reopen it if anything is missing.
Flags: needinfo?(gmarty) → needinfo?(kgrandon)
Assignee

Updated

4 years ago
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Sounds good. Just make sure the commit is linked in this bug? Thanks!
Flags: needinfo?(kgrandon)
Target Milestone: --- → 2.2 S5 (6feb)
(In reply to Kevin Grandon :kgrandon from comment #10)
> Sounds good. Just make sure the commit is linked in this bug? Thanks!

And request uplift :)
Assignee

Comment 13

4 years ago
Comment on attachment 8557042 [details] [review]
Github PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): RTL
[User impact] if declined: Bad UI for RTL languages
[Testing completed]: Manual testing
[Risk to taking this patch] (and alternatives if risky): CSS change only
[String changes made]: None
Attachment #8557042 - Flags: approval-gaia-v2.2?(bbajaj)
Issue verified fixed in Flame 3.0

With language set to Arabic, deletion confirmation screen when deleting Smart Collections, Marketplace Apps, and Browser Bookmarks from homescreen, as well as uninstalling an app from App Permissions in settings shows text as right aligned.

Adding verifyme for 2.2 verification ahead of uplift

Device: Flame 3.0 Master
Build ID: 20150210010523
Gaia: 0cf517083f7eb5fc269e1236edba50534f65e3cd
Gecko: 2cb22c058add
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Attachment #8557042 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Reporter

Comment 16

4 years ago
Posted image verify.png
This issue has been verified successfully on Flame v2.2
See attachment:verify.png
STR1:
Prerequisite: Set system language as Arabic.
1. Long press an app at homescreen.
2. Tap the "x" button to delete a app.(Such as Marketplace)
**The confirm information is right-aligned.
Rate:0/5

STR2:
1. Set system language as Arabic.
2. Launch Settings -> App Permissions.
3. Select Marketplace and tap Uninstall App button.
**The confirm message is right-aligned.
Rate:0/5

Flame 2.2 build:
Gaia-Rev        791e53728cd8018f1d7cf7efe06bbeb1179f0370
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5dec207fcbeb
Build-ID        20150212002504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150212.042208
FW-Date         Thu Feb 12 04:22:18 EST 2015
Bootloader      L1TC000118D0
Reporter

Updated

4 years ago
Reporter

Comment 17

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15439/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.