[RTL] Digits and delete button are diplayed from left to right on the Emergency dialer

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Dialer
P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: jlorenzo, Assigned: thills)

Tracking

unspecified
2.2 S5 (6feb)
x86_64
Linux
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-bug-bash])

Attachments

(6 attachments)

(Reporter)

Description

3 years ago
Prerequisites
Have the phone set in Arabic
Have a passcode set on the device

STR
1. Go to the emergency dialer
2. Input some digits

Actual result
You're able to hear the sound, but nothing appears on the dialer.
(Reporter)

Comment 1

3 years ago
Can we put this bug under the feature-b2g 2.2 flag?
Flags: needinfo?(whuang)
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
triage: P1 for confusing UI on the emergency dialer
feature-b2g: --- → 2.2+
Flags: needinfo?(whuang)
Priority: -- → P1
Target Milestone: --- → 2.2 S6 (20feb)
Flags: in-moztrap+
(Reporter)

Comment 3

3 years ago
Created attachment 8556505 [details]
Screenshot
(Reporter)

Comment 4

3 years ago
I'm not able reproduce this exact issue today (might be related to bug 1121748). But I found out that the emergency dialer is not RTL-compliant (see screenshot). Changing the bug summary to match the STR in comment 0.

Clearing also the priority to get this bug triaged with the correct information this time.
Priority: P1 → --
Summary: [RTL] No digit is displayed on the Emergency dialer in RTL → [RTL] Digits and delete button are diplayed from left to right on the Emergency dialer
feature-b2g: 2.2+ → ---
triage: reasoning in comment 2 still stands.
feature-b2g: --- → 2.2+
Priority: -- → P1

Comment 6

3 years ago
Hi Doug,
Can you help to find someone to help this bug?
Thanks!
Flags: needinfo?(drs.bugzilla)
(Assignee)

Comment 7

3 years ago
Josh,

I'll take a look at this one.
-tamara
Flags: needinfo?(drs.bugzilla)
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
QA Contact: thills
Created attachment 8560000 [details] [review]
[PullReq] tamarahills:bugfix/1126379_force_ltr_on_emergency_dialer to mozilla-b2g:master
(Assignee)

Comment 9

3 years ago
Created attachment 8560001 [details] [review]
PR for fix
Attachment #8560001 - Flags: review?(gsvelto)
Assignee: nobody → thills
QA Contact: thills
Comment on attachment 8560001 [details] [review]
PR for fix

LGTM, this bit is now identical to the dialer.
Attachment #8560001 - Flags: review?(gsvelto) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.

Updated

3 years ago
Keywords: checkin-needed
(Assignee)

Comment 13

3 years ago
https://github.com/mozilla-b2g/gaia/commit/a42e6d7ac229e1fd68391ba36df4a0c75fd6b30d

NI to myself to ask for 2.2 approval
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(thills)
Resolution: --- → FIXED

Comment 14

3 years ago
Hi Johan,
    According to bug 1102317, in bug 1102317, it describes that dialer should be displayed in LRT,So I think the Emergency call view should be displayed same as dialer view, and this issue has been verified successfuly in Flame 3.0.Could you confirm it? Thanks.

Reproduce rate:0/5.
Attachment:Verify_RTL.png

Flame 3.0 build:

Build ID               20150208010208
Gaia Revision          994896b89ba10cad39a87f90eeaba9ae5e17c3a6
Gaia Date              2015-02-07 19:22:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/be65d1fde126
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150208.050436
Firmware Date          Sun Feb  8 05:04:47 EST 2015
Bootloader             L1TC000118D0
status-b2g-master: affected → verified
Flags: needinfo?(jlorenzo)

Comment 15

3 years ago
Created attachment 8561178 [details]
Verify_RTL.png
(Reporter)

Comment 16

3 years ago
It's how it should be displayed. Thanks for verifying Coler.
Status: RESOLVED → VERIFIED
Flags: needinfo?(jlorenzo)
(Assignee)

Comment 18

3 years ago
Created attachment 8565944 [details]
2.2 Uplift request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): It's a feature request to support RTL.  Right now the non-emergency dialer is forced to LTR in RTL mode.  This change will make the emergency dialer consistent with the non-emergency dialer.
[User impact] if declined:  As per RTL team, it could be confusing to RTL users because their non-emergency dialer will be forced LTR and their emergency dialer would be RTL.
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): Low.  It's a one line change that sets the direction forced to LTR.  Would be easy to backout.
[String changes made]: No
Attachment #8565944 - Flags: approval-gaia-v2.2?(release-mgmt)

Updated

3 years ago
Attachment #8565944 - Flags: approval-gaia-v2.2?(release-mgmt) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/4b0f9079c7223126fdceed004fe13f3a2493e53f
status-b2g-v2.2: affected → fixed
Target Milestone: 2.2 S6 (20feb) → 2.2 S5 (6feb)
(Assignee)

Comment 20

3 years ago
clearing NI
Flags: needinfo?(thills)
Created attachment 8624648 [details]
Verify_Pass.png

According to comment 14 and comment 16, this problem is verified as "pass" on latest build of Flame 2.2 and Nexus5 2.2.
Actual result: On Emergency dialer view, the digits and delete button are displayed in LRT.
See attachment: Verify_Pass.png
Rate: 0/5

Device information:
Flame 2.2 (Pass)
Build ID               20150618162503
Gaia Revision          3414b07dc489976bf510fd8042c0af3b1192c160
Gaia Date              2015-06-16 22:04:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/14a1a46b54ab
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150618.195202
Firmware Date          Thu Jun 18 19:52:13 EDT 2015
Bootloader             L1TC000118D0

Nexus5 2.2 (Pass)
Build ID               20150618002507
Gaia Revision          3414b07dc489976bf510fd8042c0af3b1192c160
Gaia Date              2015-06-16 22:04:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a2db74491088
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150618.034835
Firmware Date          Thu Jun 18 03:48:52 EDT 2015
Bootloader             HHZ12f
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.