Closed Bug 1126421 Opened 8 years ago Closed 5 years ago

"Rikaichan" add-on does not work with e10s

Categories

(Firefox :: Extension Compatibility, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED INCOMPLETE
Tracking Status
e10s + ---

People

(Reporter: AsukaLangleyfag, Unassigned)

References

()

Details

(Whiteboard: [amo-author-notified])

Attachments

(2 files)

Doesn't work with e10s (Electrolysis), like Rikaichan. In non-e10s tabs all works fine.
How to reproduce:
1. Install Nightly (http://nightly.mozilla.org/)
2. Install Rikaichan or fork of Rikaichan, Rikaisama (http://rikaisama.sourceforge.net/)
3. Try it with e10s
Blocks: e10s-addons
Depends on: 1151162
It seems with the latest update 2.0.8, rikaichan is working. If someone else can confirm.
Thanks for testing, Rodze! I will close this bug based on your testing. If someone else can still reproduce the problem, they can reopen this bug or file a new one.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Rikaichan is not working when electrolysis is enabled.

Version 2.0.9 of Rikaichain (AMO: https://addons.mozilla.org/en-US/firefox/addon/rikaichan/ )

v40 Dev/Aurora Firefox

Dictionary file: May 1, 2015 release

With my own profile (multiple other addons), clicking the toolbar button for Rikaichan has no effect whatsoever.  Using the context menu option check the context menu item, but otherwise has no effect.

With a brand new profile, clicking the toolbar button for Rikaichan activates Rikaichan (and changes the icon to the starred version), and brings up a simple notification box on the top left of the screen, but otherwise does not provide any of the expected functionality of the addon (ie: live translation of Japanese text).  The notification box normally goes away after a few seconds when Rikaichan is working properly, but with electrolysis enabled, the box stays there permanently.

In both of the above cases, electrolysis was enabled.  Disabling electrolysis on the brand new profile allowed Rikaichan to function properly.

Test page: https://yaranakya.wordpress.com/2015/03/06/%E5%9B%BD%E9%9A%9B%E6%9C%80%E8%90%8C%E3%83%AA%E3%83%BC%E3%82%B0%E3%81%AF%E5%9C%92%E5%9F%8E%E5%AF%BA%E6%80%9C%E3%81%A1%E3%82%83%E3%82%93%E3%81%AB%E4%B8%80%E7%A5%A8%E3%82%92%E5%85%A5%E3%82%8C%E3%81%BE/

I cannot reopen this bug myself.
Reopening based on David's report in comment 3.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
Rikaichan works for me most of the time, but I experience a hang with e10s on that does not occur with e10s off

procedure:
1. install rikaichan + jap-en dictionary
2. restart
3. go to https://twitter.com/age_jaco/status/618987733789184000
4. hover over the tweet text "ぽんちょ"
5. rightclick -> rikaichan

result: the info popup appears in the top-left corner, then the entire UI - including chrome -  becomes unresponsive.

workaround: disable e10s

tested with: Firefox x64 on windows 7, 42.0a1, Build ID 20150709030206
I am also seeing this hang as of about a week ago. If I turn on Rikaichan and hover over any Japanese text the browser hangs and I am forced to restart.
(In reply to Brian Birtles (:birtles) from comment #6)
> I am also seeing this hang as of about a week ago. If I turn on Rikaichan
> and hover over any Japanese text the browser hangs and I am forced to
> restart.

I forgot to add, this is on Windows 8.1 on Nightly.

I suspect the regression happened sometime between July 1~10 JST. (I first noticed it on July 10 and I use this add-on pretty much every day so I guess a commit somewhere around July 8 would be most likely.)
Captured a hang that occurred when enabling rikaichan. Attached file is the parent process. Will add the child process in a followup.
And the child process debug related to the previous attachment.


And I think https://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg might need some updating, the ".childdbg 1" command doesn't seem to do anything when attaching to an already running/hung process.
I can confirm that this hang is occurring. Contacting the dev on AMO.
Whiteboard: [amo-author-notified]
If Firefox is hanging with e10s enabled, try disabling text highlighting in Rikaichan's options for now. There seems to be a problem with the way the e10s shims handle selections (used for highlighting), but I'm not completely sure.

A new version for e10s is being made which should fix shim-related issues, but unfortunately work on it has been very slow. I'm hoping at least for an alpha/test version release soon though.
Any update on this?  e10s is about to ship to beta.
Current version on AMO is still 2.0.9 (April 2015 release), however there's a development version with notes about fixing things for electrolysis (v3.0a3) that was last updated in February.

A quick test with 3.0 seems to work OK.  Testing with interposition turned off also seems to work OK, so probably fully electrolysis-compatible, rather than just shimmed.

It's still not a fully-released version, but it does appear to be just about done.
Can confirm, everything seems ok (using it the way I used release version) with 3.0a3 version.
I guess Rikaichan has broken again after the update to Firefox Developer Edition, sometime in the last week.
Currently using the said browser with e10s on.
Also checked with rikaisama.
Confirmed, broken again for me, too. Clicking the button in the toolbar does nothing, now, it doesn't even highlight.
With Firefox 57 only WebExtensions are permitted and are, by default, e10s compatible.
Status: REOPENED → RESOLVED
Closed: 8 years ago5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.