Closed Bug 1151162 Opened 8 years ago Closed 8 years ago

Rikaichan addon is broken by change to JS1.7's destructuring for…in loops

Categories

(Firefox :: Extension Compatibility, defect)

40 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox39 --- unaffected
firefox40 --- affected

People

(Reporter: rodrigozeh, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150403030204

Steps to reproduce:

Install the addon.
Press alt+insert or click the addon button.


Actual results:

Nothing.


Expected results:

Dictionary highlight should've been activated.

Problem started on 20150401 Nightly.
Important: e10s is disabled.

With e10s enabled it doesn't work either, but that's bug 1126421.
Component: Untriaged → Extension Compatibility
See Bug 1083498,
The Add-on should be revised to conform to the latest specifications.
Blocks: 1083498
Thanks (as always) for bisecting this bug, Alice! :)

I sent an email about this bug (and e10s bug 1126421) to ffjon, the developer of this add-on.

https://addons.mozilla.org/en-US/firefox/addon/rikaichan/
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 1126421
Summary: Rikaichan addon does not work → Rikaichan addon is broken by change to JS1.7's destructuring for…in loops
It seems with the latest update 2.0.8, rikaichan is working. If someone else can confirm.
Calling this fixed based on comment #4.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.