Disable theme-color when in private browsing

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System::Browser Chrome
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: kgrandon, Assigned: kgrandon)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S5 (6feb)
x86
Mac OS X

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

3 years ago
Since we're currently relying on the theme color to indicate private browsing, we should disable the theme-color meta tag from working when in a private browsing context. Alternatively we could change the menu icon to the mask perhaps? Then we probably wouldn't need to disable it.

Comment 1

3 years ago
Created attachment 8555608 [details] [review]
[PullReq] KevinGrandon:bug_1126494_disable_theme_color_private_window to mozilla-b2g:master

Comment 2

3 years ago
Created attachment 8555609 [details] [review]
[PullReq] KevinGrandon:bug_1126494_disable_theme_color_private_window to mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8555609 - Attachment is obsolete: true
(Assignee)

Comment 3

3 years ago
Comment on attachment 8555608 [details] [review]
[PullReq] KevinGrandon:bug_1126494_disable_theme_color_private_window to mozilla-b2g:master

Etienne - could you take a look here? We might change this in the future, but I think this makes the most sense for now.
Attachment #8555608 - Flags: review?(etienne)
Comment on attachment 8555608 [details] [review]
[PullReq] KevinGrandon:bug_1126494_disable_theme_color_private_window to mozilla-b2g:master

makes sense
Attachment #8555608 - Flags: review?(etienne) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Comment 5

3 years ago
Pull request has landed in master: https://github.com/mozilla-b2g/gaia/commit/47dbdb08fb298b48953e3cce09eefc34c50ff819

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

3 years ago
Comment on attachment 8555608 [details] [review]
[PullReq] KevinGrandon:bug_1126494_disable_theme_color_private_window to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature implementation.
[User impact] if declined: Possible confusion when navigating to a site with theme-color and private browsing. We may bring back theme-color in the future, but we would first need a different UX for private browsing.
[Testing completed]: Manual and unit test.
[Risk to taking this patch] (and alternatives if risky): Small, contained patch. Low risk.
[String changes made]: No.
Attachment #8555608 - Flags: approval-gaia-v2.2?(fabrice)
Attachment #8555608 - Flags: approval-gaia-v2.2?(fabrice) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/7916abb0946a132a0857a0e7afb24b8091fafcd8
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S5 (6feb)

Comment 8

2 years ago
Created attachment 8638467 [details]
verified_Flame v2.2.3gp

This bug has been verified as pass on latest Nightly Flame v2.2 & master.

STR:
1.Launch browser app.
2.Tap "new private window".
3.Put in any website in search bar, eg:www.sina.com.
4.Tap search button and enter the page.

Actual results: Theme-color is enabled and available in private browsing.
See attachment: verified_Flame v2.2.3gp
Reproduce rate: 0/6


Device: Flame 2.2 (Pass)
Build ID               20150723002503
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d8326043baec
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150723.041700
Firmware Date          Thu Jul 23 04:17:12 EDT 2015
Bootloader             L1TC000118D0

Device: Flame master (Pass)
Build ID               20150723160204
Gaia Revision          ec2199b324304d3678b6a98a08a31bdc13c9e984
Gaia Date              2015-07-23 17:16:25
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cb8bdb8ffaef
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150723.193607
Firmware Date          Thu Jul 23 19:36:19 EDT 2015
Bootloader             L1TC000118D0

Updated

2 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.