[RTL] "(Conference (2" is displayed when you're in a conference call

VERIFIED FIXED in 2.2 S5 (6feb)

Status

defect
P2
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: jlorenzo, Assigned: thills)

Tracking

unspecified
2.2 S5 (6feb)
x86_64
Linux
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(5 attachments)

Reporter

Description

5 years ago
Posted image Screenshot
Like in bug 1102344, "Conference (2)" displays "(Conference (2" when you have a conference call ongoing.

See screenshot
Target Milestone: --- → 2.2 S6 (20feb)
Flags: in-moztrap+
Assignee

Comment 2

4 years ago
Posted file PR for fix
Assignee: nobody → thills
Status: NEW → ASSIGNED
Attachment #8558127 - Flags: review?(gsvelto)
feature-b2g: --- → 2.2+
Priority: -- → P2
Comment on attachment 8558127 [details] [review]
PR for fix

Looks good to me!
Attachment #8558127 - Flags: review?(gsvelto) → review+
Assignee

Comment 5

4 years ago
NI to myself to ask for uplift.
Flags: needinfo?(thills)
Issue verified fixed on Flame 3.0

String now appears as "Conference (2)" while in conference call.

Adding verifyme keyword to check 2.2 after uplift.

Device: Flame 3.0 Master
Build ID: 20150205010209
Gaia: 1e2c128e1343668fe0ef7f8e48bf6cb60280dd19
Gecko: 34a66aaaca81
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Assignee

Comment 8

4 years ago
Posted file 2.2 Uplift request
[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):It's a new feature to support RTL
[User impact] if declined: An RTL user would see the Conference(2) string in an incorrect format.  
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky):  Low.  
[String changes made]: No
Attachment #8565946 - Flags: approval-gaia-v2.2?(release-mgmt)
Attachment #8565946 - Flags: approval-gaia-v2.2?(release-mgmt) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/777c88acde2dc130ccc83a962dca2092df056ffe

BTW, you can just put the approval request on the Pull Request attachment rather than creating a new attachment just for that.
Target Milestone: 2.2 S6 (20feb) → 2.2 S5 (6feb)
Assignee

Comment 10

4 years ago
clearing NI
Flags: needinfo?(thills)

Comment 11

4 years ago
This issue has been verified successfully on Flame v2.2, "Conference" displays as Arabic and shows at right side of "(2)" when you have a conference call ongoing.
See attachment:2015-02-26-14-31-51.png
Rate:0/5

Flame 2.2 build:
Build ID               20150225002505
Gaia Revision          ca64f2fe145909f31af266b1730874051ba76c78
Gaia Date              2015-02-24 22:06:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/16804008c29f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.041814
Firmware Date          Wed Feb 25 04:18:25 EST 2015
Bootloader             L1TC000118D0

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.