Closed Bug 1126964 Opened 5 years ago Closed 5 years ago

Rocketbar background flashes when entering the search app

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

x86
macOS
defect
Not set

Tracking

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S6 (20feb)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: kgrandon, Assigned: daleharvey)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(2 files, 1 obsolete file)

Probably also caused by Bug 1117968, currently when you enter rocketbar there is a distracting flash. It's not clear if bug 1125810 will resolve this, but I'm filing another bug to track it at least until it's fixed.

STR:
1- Tap rocketbar on home screen.

Expected result:
The input background will not flash.

Actual result:
The input background flashes.
Assignee: nobody → dale
Comment on attachment 8560907 [details] [review]
[PullReq] daleharvey:1126964 to mozilla-b2g:master

This fixes a few small layout issues that were too much to be split into seperate patches, main ones are

1. Open transition, should fade in when results start showing, background should be darker
2. Position of offline message
3. Padding between the shown headings
4. Border below the places results (the border has padding but the active background shouldnt

Visuals to check against are @ https://mozilla.app.box.com/s/gpijv051aeivyoxcz72a
Attachment #8560907 - Flags: review?(kgrandon)
Attachment #8560907 - Flags: review?(bfrancis)
Comment on attachment 8560908 [details] [review]
[PullReq] daleharvey:1126964 to mozilla-b2g:master

I have no idea why this attached twice. Need to look into that.
Attachment #8560908 - Attachment is obsolete: true
I closed and reopened it, may be why
Comment on attachment 8560907 [details] [review]
[PullReq] daleharvey:1126964 to mozilla-b2g:master

This is looking much more polished, nice work!
Attachment #8560907 - Flags: review?(kgrandon) → review+
Awesome thanks, landed in https://github.com/mozilla-b2g/gaia/commit/be3a2109d78207e5cfae3ec4597b598dc827a96c

Gregor also feature 2.2
Flags: needinfo?(anygregor)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8560907 [details] [review]
[PullReq] daleharvey:1126964 to mozilla-b2g:master

Clearing review
Attachment #8560907 - Flags: review?(bfrancis)
Duplicate of this bug: 1131049
feature-b2g: --- → 2.2+
Flags: needinfo?(anygregor)
Adding qawanted for verification.
Keywords: qawanted, verifyme
This issue is verified fixed on Flame 3.0. Rocketbar search field no longer flashes upon enabling it via Homescreen.

The duped bug 1131049 is also verified fixed. Background appears translucent when enabling Rocketbar search.

I noticed that as soon as I typed a letter into Rocketbar, background becomes opaque gray again. I read the user story on bug 1125810 ( https://mozilla.app.box.com/s/gpijv051aeivyoxcz72a ), it seems to be an expected behavior.

Tested on:
Device: Flame 3.0 (full flash)
BuildID: 20150209133005
Gaia: 0cf517083f7eb5fc269e1236edba50534f65e3cd
Gecko: 1af029247ca5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

-----

Since 2.2 has just been uplifted, we need to wait til tomorrow for a build that contains the fix. Leaving verifyme keyword for 2.2 verify.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
Did this get approval for uplift somewhere outside the bug?
Flags: needinfo?(dale)
Target Milestone: --- → 2.2 S6 (20feb)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
> Did this get approval for uplift somewhere outside the bug?

Its feature-b2g 2.2+, do we need seperate approval to land 2.2+'d feature work before FC?
Flags: needinfo?(dale) → needinfo?(ryanvm)
The policy is the same as it has always been. *All* patches require approval regardless of status. It's also clearly spelled out on the B2G Landing wiki.
Flags: needinfo?(ryanvm)
Comment on attachment 8560907 [details] [review]
[PullReq] daleharvey:1126964 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 2.2 Feature Development, accidentally already landed without approval, proactively asking for approval
[User impact] if declined:
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:
Attachment #8560907 - Flags: approval-gaia-v2.2?
Attachment #8560907 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Per Comment 12, this bug has been successfully verified on latest Flame v2.2.

See attachment: verified_v2.2.mp4.
Reproduce rate: 0/5.

STR:
1. Tap Rocketbar on homescreen.
**Rocketbar search field no longer flashes.And background appears translucent.
2. Type a letter or dot (.) in Rocketbar.
**Background becomes opaque gray.

Flame 2.2 build:
Build ID               20150210002516
Gaia Revision          b30c8e4303595a0fcb5b640d673cf8503b954701
Gaia Date              2015-02-10 04:09:47
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3e9fa4e70a1b
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150210.041059
Firmware Date          Tue Feb 10 04:11:10 EST 2015
Bootloader             L1TC000118D0
Whiteboard: [systemsfe]
You need to log in before you can comment on or make changes to this bug.