Closed Bug 1127148 Opened 5 years ago Closed 4 years ago

[RTL] cursor for email and password when setting up a new account starts on left instead of right

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.2 affected, b2g-master affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: nhirata, Unassigned)

References

Details

(Whiteboard: [2.2-bug-bash])

Attachments

(2 files)

Build ID               20150128010234
Gaia Revision          1d53fb07984298253aad64bfa4236b7167ee3d4d
Gaia Date              2015-01-27 16:20:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b2b10231606b
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150127.035842
Firmware Date          Tue Jan 27 03:58:52 EST 2015
Bootloader             L1TC000118D0


Steps to Reproduce
1. set device to RTL
2. launch email
3. tap in the name field or email field

Expected Results
cursor should be on right hand side

Actual Results
cursor is on left hand side.

Other Notes


Reproduction Frequency:
Flags: in-moztrap-
Seems like this is a dupe of Bug 1064640.
Apparently as per https://bugzilla.mozilla.org/show_bug.cgi?id=1064640#c20 there, this is the correct behavior for Email.

Coler: please adapt your TC when you create it, in order to reflect behavior described in https://bugzilla.mozilla.org/show_bug.cgi?id=1064640#c20

thanks!
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1064640
This still occurs after bug 1064640 has been verified fix. The text cursor will switch to RTL after a RTL defined language has begun typing, however before then it will stay on the left-hand side, anticipating an LTR language. This overlaps slightly with the 'X' icon to clear the text field. Attached image. 
This creates at least two scenarios where the behavior of the cursor is inconsistent:
When writing an email, the cursor will begin at the right for both RTL and LTR languages.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
triage: P3 for limited visibility (I've only seen this on the email setup screen so far) and no impact to functionality.
Priority: -- → P3
This issue cannot reproduced on latest Flame 2.2/3.0 and N5 2.2/3.0 build by the STR in comment 0, Cursor is right-alinged in the input field on sign in view.
If anyone can repro it, reopen again.
See attachment:Email_Text cursor_Pass.png
Device informations: 
Flame 2.2 Build ID 20150528162502
Flame 3.0 Build ID 20150528160205
Nexus5 2.2 Build ID 20150528162502
Nexus5_3.0 Build ID 20150528160205
Status: REOPENED → RESOLVED
Closed: 5 years ago4 years ago
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.