bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[Loop] When GSM call is in progress in device, if user tries to join to a Room (created), the GSM call sound is listened in speaker.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Loop
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: lolimartinezcr, Assigned: jaoo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Room1.1.1_TestRun2])

(Reporter)

Description

4 years ago
Fire E 2.0
Loop 1.1.1/d4d66d37

Prerequisites:
Device A logged in Mobile Loop application with FxA.
Device B logged in Mobile Loop application with MobileID.
Device A has created and shared a room.

STRs:
1. Device B makes a GSM call to Device A.
2. Device A picks up the GSM call -> call is established.
3. Device A taps on "home" button and taps on "Loop" application.
4. Device A select the room (created).

Actual result:
While "Select camera" screen is shown and Message error is shown, the GSM call sound is listened in speaker.

Expected result:
While "Select camera" screen is shown and Message error is shown, the GSM call sound isn't listened in speaker.
(Reporter)

Updated

4 years ago
Whiteboard: [Room1.1.1_TestRun2]
(Assignee)

Updated

4 years ago
Assignee: nobody → josea.olivera
Status: NEW → ASSIGNED
(Assignee)

Comment 1

4 years ago
Landed on master branch at:

https://github.com/mozilla-b2g/firefoxos-loop-client/commit/3c23b0bd3e4cdce06d785c24ca53018f277323d3
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [Room1.1.1_TestRun2] → [Room1.1.1_TestRun2][Not in 1.1.1]
(Assignee)

Comment 2

4 years ago
Sorry I resolved this by mistake. I mean bug 1127320.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

4 years ago
Whiteboard: [Room1.1.1_TestRun2][Not in 1.1.1] → [Room1.1.1_TestRun2]
(Assignee)

Comment 3

4 years ago
The root cause of this bug is the same that the one from bug 1127384. As I commented in that bug I don't see any user trying to join a room while a GSM/CDMA call is active. Sadly we don't have a way to check whether the GSM/CDMA call is active by the moment the user joins the room. I would resolve this bug as well as WONTFIX IMHO, thoughts?
(Assignee)

Updated

4 years ago
Flags: needinfo?(oteo)
(Assignee)

Comment 4

4 years ago
As per comment 3 let's resolve this as WONTFIX.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(oteo)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.