Closed Bug 1127613 Opened 8 years ago Closed 8 years ago

TabsPanel reanimates when switching between tabs tab types

Categories

(Firefox for Android Graveyard :: General, defect)

All
Android
defect
Not set
normal

Tracking

(firefox38 verified, fennec38+)

VERIFIED FIXED
Firefox 38
Tracking Status
firefox38 --- verified
fennec 38+ ---

People

(Reporter: mcomella, Assigned: fedepaol)

References

Details

(Keywords: regression)

Attachments

(1 file)

1) Open the TabsPanel
2) Switch the tabs tray to private

Expected: Does not animate
Actual: Animates

NI Martyn to make sure he sees this. Let's make sure we didn't uplift this!
Flags: needinfo?(mhaigh)
I can't reproduce this - can you give me more info about what branch you're seeing this on and what device?
Flags: needinfo?(mhaigh) → needinfo?(michael.l.comella)
(In reply to Martyn Haigh (:mhaigh) from comment #1)
> I can't reproduce this - can you give me more info about what branch you're
> seeing this on and what device?

fx-team from yesterday, but it wasn't in yesterday's Nightly - liuche could also repro with her build.
Flags: needinfo?(michael.l.comella)
Regression window wanted:
fx-team:
good build: 1422552036 
bad build: 1422557070 

pushlog: http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=65f735ba947e&tochange=982fcfb63679
Blocks: 909434
tracking-fennec: --- → ?
Keywords: regression
Federico, can you take a look at this?
Assignee: mhaigh → fedepaol
No longer blocks: new-tablet-v1
Status: NEW → ASSIGNED
Flags: needinfo?(fedepaol)
Attached patch bug-1127613-fixSplinter Review
Done! Sorry for causing so much trouble..

Note: could not add mHeaderVisible = true directly in prepareToShow() because it had to be flipped after dispatchLayoutChange.
For that reason I had to add it also in prepareToDrag
Flags: needinfo?(fedepaol)
Attachment #8558090 - Flags: review?(michael.l.comella)
Attachment #8558090 - Flags: review?(michael.l.comella) → review?(wjohnston)
Attachment #8558090 - Flags: review?(wjohnston) → review+
tracking-fennec: ? → 38+
https://hg.mozilla.org/mozilla-central/rev/83ffa6446310
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 38
TabsPanel does not animate when switching between normal and private tabs, so:
Verified as fixed on:
Device: Nexus 5 (Android 5.0.1)
Build: Firefox for Android 38.0a1 (2015-02-19)
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.