Closed Bug 1127621 Opened 5 years ago Closed 5 years ago

Checkboxes not visible on about:welcomeback

Categories

(Firefox :: General, defect)

All
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 38
Iteration:
38.3 - 23 Feb
Tracking Status
firefox37 --- unaffected
firefox38 + fixed

People

(Reporter: MattN, Assigned: ntim)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Screen Shot
I can't see any checkboxes and I'm not able to toggle them. I'm guessing this is related to bug 1087618 but perhaps it was broken before.

[Tracking Requested - why for this release]: regression (version unknown)
Flags: firefox-backlog+
This looks like a regression of bug 1087618. about:welcomeback used to include the about:sessionrestore stylesheet, which included the styles for the checkmarks.

To fix this, we can simply copy over the checkbox style from about:sessionrestore to about:welcomeback.
Let's get this fixed soon while it's still fresh.  Tim - assigning to you, but feel free to re-assign to another dev if one is available.
Assignee: nobody → ntim007
Status: NEW → ASSIGNED
I should be able to fix this (along with other regressions) by the end of next week.
Attached patch Patch (r=jaws)Splinter Review
This was r+ed in bug 1128882. Just split up the changes at jaws' request.
Attachment #8564306 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/3ad37a67d2d5
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 38
Iteration: --- → 38.3 - 23 Feb
Flags: qe-verify?
You need to log in before you can comment on or make changes to this bug.