Closed Bug 1128882 Opened 5 years ago Closed 5 years ago

[e10s] Unable to Restore all tabs after Refreshing Nightly

Categories

(Firefox :: General, defect)

38 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 38
Tracking Status
e10s m8+ ---
firefox38 --- fixed

People

(Reporter: adalucinet, Assigned: ntim)

References

Details

Attachments

(1 file, 1 obsolete file)

Reproducible on Nightly 38.0a1 (Build ID: 20150202030232) *only* with e10s enabled
Platforms: Windows 7 64-bit, Ubuntu 14.04 32-bit, Mac OS X 10.9.5 and 10.10

Steps to reproduce:
1. Launch Nightly.
2. Go to about:support
3. Refresh Nightly.
4. After refresh is applied, select any of the 2 available options ('Restore all Windows and Tabs' or 'Restore only the ones you want') and click 'Let's go' button.

Expected result: Tabs/Windows are successfully restored.
Actual result: Tabs/Windows are not restored.

Notes:
1. Regressed by bug 1087618
2. Screencast: http://goo.gl/tnvwNa
3. Browser Console output: 'TypeError: document.getElementById(...) is null' message thrown by boutSessionRestore.js:109:2
Ups, forgot to add the fact that I'm unable to select which tabs to restore via 'Restore only the ones you want' option, issue visible also in the screencast.
Assignee: nobody → ntim007
Status: NEW → ASSIGNED
Attached patch Patch (obsolete) — Splinter Review
Turns out the errorTryAgain id is also needed for aboutWelcomeBack.

Fixes bug 1127621 as well.
Attachment #8560006 - Flags: review?(jaws)
Comment on attachment 8560006 [details] [diff] [review]
Patch

Review of attachment 8560006 [details] [diff] [review]:
-----------------------------------------------------------------

Please separate these patches out so that the aboutWelcomeBack.css changes are in bug 1128882. r=me for both changes.

::: browser/themes/shared/aboutWelcomeBack.css
@@ +23,5 @@
> +
> +treechildren::-moz-tree-image(icon),
> +treechildren::-moz-tree-image(noicon) {
> +  padding-right: 2px;
> +  margin: 0px 2px;

margin: 0 2px;
Attachment #8560006 - Flags: review?(jaws) → review+
Attached patch Patch v2Splinter Review
Split up the checkbox fix in bug 1127621.
Attachment #8560006 - Attachment is obsolete: true
Attachment #8564307 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/9fe9d717e571
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 38
Bug is fixed!
QA Whiteboard: [good first verify]
Mistakenly filed against Firefox 38 and should be instead 38 Branch. Sorry for the spam. dkl
Version: Firefox 38 → 38 Branch
OS : Windows 7 ultimate 64-bit.
I have tried to reproduced the bug on nightly 38.0a1(20150202030232)and I have seen the bug in it.
The fixed is verified on nightly 41.0a1(20150521030204).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.