Closed Bug 1127659 Opened 7 years ago Closed 7 years ago

[Dialer] Should copy the whole number instead of ... when number is too long

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

x86
macOS
defect
Not set
normal

Tracking

(blocking-b2g:-)

RESOLVED DUPLICATE of bug 1121586
blocking-b2g -

People

(Reporter: gduan, Unassigned)

References

Details

Attachments

(1 file)

STR:
1. type long number and it would show ...12345678899
2. long tap the number and press copy

Expect:
whole number is copied
Actual:
...1234568899 is copied.
[Blocking Requested - why for this release]: New functionality which is broken on a standard use case.
blocking-b2g: --- → 2.2?
Blocks: CopyPasteGaia
No longer blocks: CopyPasteLegacy
Hi Omega,
Could you please comment on the expected behavior?
1. should the user be able to select the number?
2. should the user be able to select "..."?
Flags: needinfo?(ofeng)
We decided not to allow Text Selection here, see here for more details:
https://bugzilla.mozilla.org/show_bug.cgi?id=1121586#c21
Flags: needinfo?(ofeng)
Per comment4, actually text selection shouldn't be allowed. 
Once bug 1121586 gets fixed, this isn't an issue at all.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1121586
blocking-b2g: 2.2? → -
You need to log in before you can comment on or make changes to this bug.