If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[flatfish] build break in gecko/dom/system/gonk/GonkGPSGeolocationProvider.cpp

RESOLVED FIXED in Firefox 38

Status

Firefox OS
General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: dliang, Assigned: sku)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(firefox38 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

3 years ago
Created attachment 8556848 [details]
build.log

Below is error message:
In file included from Unified_cpp_dom_system_gonk0.cpp:38:0:
../../../../gecko/dom/system/gonk/GonkGPSGeolocationProvider.cpp: In member function 'virtual nsresult GonkGPSGeolocationProvider::Startup()':
../../../../gecko/dom/system/gonk/GonkGPSGeolocationProvider.cpp:874:7: error: 'mObservingSettingsChange' was not declared in this scope
       mObservingSettingsChange = true;
       ^
In file included from Unified_cpp_dom_system_gonk0.cpp:38:0:
../../../../gecko/dom/system/gonk/GonkGPSGeolocationProvider.cpp: In member function 'virtual nsresult GonkGPSGeolocationProvider::Shutdown()':
../../../../gecko/dom/system/gonk/GonkGPSGeolocationProvider.cpp:941:7: error: 'mObservingSettingsChange' was not declared in this scope
       mObservingSettingsChange = false;
       ^
In file included from Unified_cpp_dom_system_gonk0.cpp:38:0:
../../../../gecko/dom/system/gonk/GonkGPSGeolocationProvider.cpp: In member function 'virtual nsresult GonkGPSGeolocationProvider::Observe(nsISupports*, const char*, const char16_t*)':
../../../../gecko/dom/system/gonk/GonkGPSGeolocationProvider.cpp:1074:41: error: 'kSettingRilDefaultServiceId' was not declared in this scope
     } else if (setting.mKey.EqualsASCII(kSettingRilDefaultServiceId)) {
                                         ^
../../../../gecko/dom/system/gonk/GonkGPSGeolocationProvider.cpp:1076:57: error: 'IsValidRilServiceId' was not declared in this scope
           !IsValidRilServiceId(setting.mValue.toNumber())) {
                                                         ^
../../../../gecko/dom/system/gonk/GonkGPSGeolocationProvider.cpp:1080:7: error: 'mRilDataServiceId' was not declared in this scope
       mRilDataServiceId = setting.mValue.toNumber();
       ^
../../../../gecko/dom/system/gonk/GonkGPSGeolocationProvider.cpp:1081:28: error: 'UpdateRadioInterface' was not declared in this scope
       UpdateRadioInterface();
(Reporter)

Comment 1

3 years ago
Hi Sku,
The build break might be caused by your commit, could you help to check it?

commit 32fc68464e9007d8c9248d09d22d7a319501897f
Author: Shawn Ku <sku@mozilla.com>
Date:   Mon Jan 19 10:51:57 2015 +0800

    Bug 878748 - [dolphin] B2G GPS: acquire correct RadioInterface instance in MultiSIM configuration. r=KanRu.
Flags: needinfo?(sku)
(Assignee)

Updated

3 years ago
Assignee: nobody → sku
Flags: needinfo?(sku)
Blocks: 1123077
(Assignee)

Comment 2

3 years ago
Created attachment 8557035 [details] [diff] [review]
Bug 1127690 - [flatfish] build break in gecko/dom/system/gonk/GonkGPSGeolocationProvider.cpp
(Assignee)

Updated

3 years ago
Attachment #8557035 - Flags: review?(kchen)
Attachment #8557035 - Flags: review?(kchen) → review+
Duplicate of this bug: 1126497
(Assignee)

Comment 4

3 years ago
Created attachment 8557690 [details] [diff] [review]
Bug 1127690 - [flatfish] build break in gecko/dom/system/gonk/GonkGPSGeolocationProvider.cpp. r=KanRu.
Attachment #8556848 - Attachment is obsolete: true
Attachment #8557035 - Attachment is obsolete: true
Attachment #8557690 - Flags: review+
(Assignee)

Comment 5

3 years ago
try looks good.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=55d19bc151a8
Keywords: checkin-needed
https://hg.mozilla.org/integration/b2g-inbound/rev/169dc0d84256
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/169dc0d84256
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox38: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S5 (6feb)
You need to log in before you can comment on or make changes to this bug.