[TextSelection] Utility bubble will still shows after tapping cut icon in rocket bar

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: gchang, Assigned: mtseng)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-CP-bug-bash])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Description
The utility bubble will still show in screen after tapping cut icon in rocket bar.

Steps to Reproduce
1. Click the "Search or enter address"
2. Type some characters
3. Long press on any character to bring up the utility bubble
4. Tap cut icon

Expected Results
The utility bubble will disappear.

Actual Results
The utility bubble still shows in the screen.

Other Notes


Reproduction Frequency: 
Always
(Reporter)

Updated

4 years ago
QA Whiteboard: [textselection]
(Reporter)

Comment 1

4 years ago
Posted image screenshot
Looks like blur issue.
Component: Gaia::System → Selection
Product: Firefox OS → Core
Version: unspecified → Trunk
Priority: -- → P2
(Reporter)

Updated

4 years ago
QA Whiteboard: [textselection] → [COM=Text Selection]
Comment on attachment 8564876 [details] [review]
[gaia] mephisto41:bug1127753 > mozilla-b2g:master

r=gduan
Attachment #8564876 - Flags: review+
master: https://github.com/mozilla-b2g/gaia/commit/897336121dfb6a090c0a885b5953b463479b2a99
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Assignee: nobody → mtseng
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → 2.2+
Component: Selection → Gaia::System
Product: Core → Firefox OS
Version: Trunk → unspecified
Comment on attachment 8564876 [details] [review]
[gaia] mephisto41:bug1127753 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none
[User impact] if declined: Bubble don't dismiss after tap cut function.
[Testing completed]: on master
[Risk to taking this patch] (and alternatives if risky): low risk
[String changes made]: none
Attachment #8564876 - Flags: approval-gaia-v2.2?
Attachment #8564876 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on Flame Master and 2.2.

Result: The copy/paste bubble gets dismissed when the user selects the cut button.
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150302010223
Gaia: f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gecko: eea6188b9b05
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150302002504
Gaia: 77609916ca5ab721150fab2b7bc5c37f43ee3a5a
Gecko: 27ab8aa34201
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Text Selection] → [QAnalyst-Triage?][COM=Text Selection]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][COM=Text Selection] → [QAnalyst-Triage+][COM=Text Selection]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.