[RTL][First Time Experience]The login page is not right-aligned.

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: sfoster)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

Reporter

Description

4 years ago
Posted image loginaccount.png
[1.Description]:
[RTL][First Time Experience]When you log in an account at FTE, the words and check box in all login page are not right-aligned.
See attachment:loginaccount.png

[2.Testing Steps]: 
1. Reset device.
2. Select Arabic as system language at FTE.
3. Press Next button and connect an available Wi-Fi.
4. Press Next button and switch to "Firefox Accounts" page.
5. Tap "Create Account or Sign In" button, input an email and tap Next button.
6. Tap Next button and observe the input password page.
7. Input the correct password and tap Next button.

[3.Expected Result]: 
4&6&7. The login page should be right-aligned.

[4.Actual Result]: 
4&6&7. The words and check box in whole login page are left-aligned.

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        6e494f1d2676d231abba7dcc2e2822d1170d2d02
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5e6fac01a72f
Build-ID        20150129003432
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150129.042943
FW-Date         Thu Jan 29 04:29:53 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Updated

4 years ago
QA Whiteboard: [rtl-impact]
triage: not quite blocking, but this is a high priority P2 for the visibility factor in FTE.
feature-b2g: --- → 2.2+
Priority: -- → P2
Whiteboard: [systemsfe]
Assignee

Comment 3

4 years ago
Comment on attachment 8558789 [details] [review]
[PullReq] sfoster:ftu-fxa-rtl-bug-1127760 to mozilla-b2g:master

The text in the login screen was explicitly aligned left. This patch adds overrides for RTL. 

It could be the progressbar change (tracked as bug 1107055) belongs in the component's CSS, but I'm not sure it will be appropriate for all uses (e.g. indeterminate?) so I've kept the patch specific for FxA here.
Attachment #8558789 - Flags: review?(ferjmoreno)
Assignee

Updated

4 years ago
Assignee: nobody → sfoster
Target Milestone: --- → 2.2 S5 (6feb)
Comment on attachment 8558789 [details] [review]
[PullReq] sfoster:ftu-fxa-rtl-bug-1127760 to mozilla-b2g:master

Thank you Sam. LGTM, but I am not the best person to review CSS changes.
Attachment #8558789 - Flags: review?(ferjmoreno)
Attachment #8558789 - Flags: review?(6a68)
Attachment #8558789 - Flags: feedback+
Assignee

Comment 5

4 years ago
Would love to land this this week, its one of the last blockers for RTL in First Time Experience. Is there anyone else that could review?
Flags: needinfo?(ianb)
If Borja's no longer doing css reviews, I'd say you will have to ask one of the system app peers. I'm not a peer/owner, sorry Sam.
Target Milestone: 2.2 S5 (6feb) → 2.2 S6 (20feb)
Assignee

Comment 7

4 years ago
Comment on attachment 8558789 [details] [review]
[PullReq] sfoster:ftu-fxa-rtl-bug-1127760 to mozilla-b2g:master

Can you look at this Etienne?
Attachment #8558789 - Flags: review?(etienne)
Flags: needinfo?(ianb)
Comment on attachment 8558789 [details] [review]
[PullReq] sfoster:ftu-fxa-rtl-bug-1127760 to mozilla-b2g:master

Looking good, I think we've missed the "show password checkbox", still left align it seems.

But after that it should be a quick r+

sorry for the delay!
Attachment #8558789 - Flags: review?(etienne)
Assignee

Comment 9

4 years ago
Comment on attachment 8558789 [details] [review]
[PullReq] sfoster:ftu-fxa-rtl-bug-1127760 to mozilla-b2g:master

PR updated with the show password thing now behaving in RTL
Attachment #8558789 - Flags: review?(etienne)
Attachment #8558789 - Flags: review?(etienne) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/27890

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Let's try this again :)
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
This issue is verified fixed on Flame Master.

Result: FxA login screen are right-aligned.
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150224010314
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 368c62292249
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
==========================

leaving verifyme for 2.2 uplift and verification.
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Reporter

Comment 14

4 years ago
(In reply to Autolander from comment #12)
> Pull request has landed in master:
> https://github.com/mozilla-b2g/gaia/commit/
> a086bb3529bacfe8f3e41776c2199132a6c3e521

Hi Autolander,
Could you help to request uplift on v2.2? Thanks!
Flags: needinfo?(bug.autolander)
Comment on attachment 8558789 [details] [review]
[PullReq] sfoster:ftu-fxa-rtl-bug-1127760 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): First Time Experience / Fx Accounts Screen
[User impact] if declined: When stepping through the FTE or configuring a fx account in a RTL language, this page will be inconsistently aligned, confusing and potentially illegible. 
[Testing completed]: On device, Gaia-Try
[Risk to taking this patch] (and alternatives if risky): Low risk, CSS-only change to the FxA stylesheet to handle RTL
[String changes made]: None
Attachment #8558789 - Flags: approval-gaia-v2.2?
Attachment #8558789 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Reporter

Comment 17

4 years ago
This issue has been verified successfully on Flame 2.2, all views in "Create Account or Sign In" at FTE are right-aligned and displayed correctly.
Rate:0/5

Flame 2.2 build:
uild ID               20150312002501
Gaia Revision          572d60e0a440ee4af50bc6b6adad8876eadbdb4d
Gaia Date              2015-03-12 01:29:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/244e6ba3c20e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150312.040315
Firmware Date          Thu Mar 12 04:03:26 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
Keywords: verifyme
Assignee

Updated

4 years ago
Duplicate of this bug: 1107055
Reporter

Comment 19

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15499/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.