Inconsistency with hand pointer on Windows and Flash plug-in pointer

RESOLVED INVALID

Status

()

RESOLVED INVALID
17 years ago
5 years ago

People

(Reporter: wolruf, Assigned: peterl-bugs)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPME], URL)

(Reporter)

Description

17 years ago
Build ID: 2001112903 on Win2k, Flash 5.0r41.

This build now has a hand as pointer on Windows thanks to bug 104035.

Steps to reproduce bug:
1. Load URL http://www.macromedia.com/software/flash/ ,
2. Move mouse over top bar, 'Products' 'Support' ,
3. See the cursor being a hand,
4. This hand is different than the one you get when mouse is over a HTML link.

There're inconsistencies with Flash as it still uses the 'old' cursor.
Is this a bug or a feature that can't be fixed unless Macromedia updates its
Flash plug-in ?

I'm not submitting this bug in 'Plug-ins' component as it's a direct consequence
of bug 104035.

Comment 1

17 years ago
-> Plug-ins

Is there a hard-coded cursor to use in Mozilla's plugin code, or is the plugin
author responsible for this?

If it's hard-coded in Mozilla, it's a valid bug, if this is due to Macromedia's
lac of style it's a bug in Flash.  ;-)
Assignee: blakeross → av
Component: XP Apps: GUI Features → Plug-ins
QA Contact: sairuh → shrir

Comment 2

17 years ago
hardly. if we don't expose a way for plugin authors to get our hand, then it's our bug.

Comment 3

17 years ago
The hand i see when playing flash on linux is not a hand from either moz nor
linux, as far as i know. Never seen that hand other places than in flash
animations. I always thought they provided their own?

Comment 4

17 years ago
related to bug 50883?

Comment 5

17 years ago
This is an evangelism bug.
On Windows the hand cursor was hardcoded ever since the early days of Netscape.
However, Microsoft have got a hand cursor that's selectable from the control
panel, so Mozilla now uses the system hand (so you can change it back to the
Netscape hand if you want to).

So on Windows Macromedia just need to modify their plugin to use the system
hand, rather than hardcode the one that Netscape used to use.

I don't think they'll do this until the first major Netscape release (MachV?)
that uses the system hand.

As for Linux... the hand you see in flash is the same as the one you see under
Windows, looks like they just used the win32 hand when they were porting it to
Linux. The old Windows Netscape hand was never used on Linux.
Component: Plug-ins → Plugins
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 6

17 years ago
NO! Don't make that assertion, it's dead wrong. And your comment even hints at 
why it would be dead wrong.

Mozilla needs to expose an api for Shockwave otherwise if mozilla's hand is 
again set not to match the system, shockwave will have this bug (again).

av: i'm resetting the priority to normal, please provide an answer to the 
simple question of: does mozilla provide an api to plugins to get our cursors?
of course, if the answer is yes it'd be nice if you indicated what the api is 
:)
Severity: minor → normal
Component: Plugins → Plug-ins
Product: Tech Evangelism → Browser
Version: unspecified → other

Comment 7

17 years ago
But the whole idea of using the system pointer (setting the system pointer to
use the old netscape hand is still using the system pointer - IE will then use
the netscape hand) is that the pointer will be consistent with all apps from the
system. Therefore it removes the need for the plugin API to expose the cursor
used, it should get it from the OS.

This is blantantly an evangelism bug, to get Macromedia to use the system hand. 

Comment 8

17 years ago
If the mouse cursor is exposed via the plugin api, it will/should work on all
platforms right?

Comment 9

17 years ago
It's probably because we aren't sending WM_SETCURSOR events on Windows...but I
thought this was only for windowless???
Assignee: av → peterl
Whiteboard: [DUPME]

Comment 10

17 years ago

*** This bug has been marked as a duplicate of 118877 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 11

17 years ago
Flash 6.0 r21 still has the same behaviour using build 2002031708 on Win2k.
Tested today with the url http://www.macromedia.com and we still have 2
different hand cursors, one for the html links in the page and another(the old
netscape hand) for the links of the flash toolbar.

dont works for me : Win2k, build(2002032003)

I also disagree that this is a duplicate of bug 118877, we should reopen this bug.

Comment 13

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED

Comment 14

16 years ago
*** Bug 206635 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
Hmm... bug 118877 is marked as Fixed.
This but is marked as a duplicate of bug 118877, yet the problem remains.

Do we need to reopen this bug?
(Reporter)

Comment 16

16 years ago
couldn't find any evangelism bug on this issue, is the fix to have Macromedia
use the system pointer for Flash plug-in ? If so, let's move this one to TE.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 17

13 years ago
Macromedia Flash 8.0b434 still doesn't have system hand on MacOSX neither on
WinXP (tested FF DPa2 and Camino 0.9a2)
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 18

13 years ago
Still not fixed using Flash 8.5, I dropped a note on Macromedia forums:
http://www.macromedia.com/cfusion/webforums/forum/messageview.cfm?catid=581&threadid=1076779&enterthread=y
(Reporter)

Comment 19

13 years ago
Not a Mozilla bug, tired of asking Macromedia for the past 4 years, closing.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 20

13 years ago
Good news, on Windows at least, Macromedia fixed this with Flash 8.5.0.212.
You need to log in before you can comment on or make changes to this bug.