Badly fixed protocol relative URLs

RESOLVED FIXED

Status

()

Firefox for iOS
Reader View
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: st3fan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
http://www.theguardian.com/cities/2015/jan/28/china-pearl-river-delta-overtake-tokyo-world-largest-megacity-urban-area

There is an image of a map in the middle of the page with the following src:

src="//i.guim.co.uk/static/w-620/h--/q-95/sys-images/Guardian/Pix/pictures/2015/1/27/1422377298156/8fd6b8d4-59f6-463a-aada-472eaa5f5ab9-620x469.png"

In reader mode this image is not loaded because it's src has changed to:

src="http:://i.guim.co.uk/static/w-620/h--/q-95/sys-images/Guardian/Pix/pictures/2015/1/27/1422377298156/8fd6b8d4-59f6-463a-aada-472eaa5f5ab9-620x469.png"
(Reporter)

Comment 1

3 years ago
The problem is that we set Readability._uri.scheme to document.location.protocol, which as a trailing :
(Reporter)

Updated

3 years ago
Summary: Missing image because of malformed url → Badly fixed protocol relative URLs
See Also: → bug 1128718
(Reporter)

Comment 2

3 years ago
Fixed with https://github.com/mozilla/firefox-ios/commit/1a591aa649d5aad3b085d6d3c958ab4b5141cc7c
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.