Closed Bug 1128376 Opened 5 years ago Closed 5 years ago

Opening card view from a landscape view app results in zoomed card

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:2.2+)

VERIFIED DUPLICATE of bug 1120974
blocking-b2g 2.2+

People

(Reporter: hcheng, Assigned: cwiiis)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

*Description:
After Bug 1118390 was landed, I 

*Reproduce steps: (100%)
1. open Gallery app
2. turn it to landscape mode
3. long tap home button to enter Card View

*Expected result:
I would expect to see a vertical card with a snapshot which is what I saw at Gallery app even if it is a landscape screenshot.

*Actual result:
See a wired and zoomed snapshot at Gallery Card View.

*Env info:
Build ID               20150201002504
Gaia Revision          d6141fa3208f224393269e17c39d1fe53b7e6a05
Gaia Date              2015-01-30 03:46:29
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f7414413e3a5
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150201.043120
Firmware Date          Sun Feb  1 04:31:31 EST 2015
Bootloader             L1TC000118D0
(In reply to Hermes Cheng[:hermescheng] from comment #0)
> *Description:
> After Bug 1118390 was landed, I 
submit too fast...

After Bug 1118390 was landed, the zoomed card for a landscape app is found.

> 
> *Reproduce steps: (100%)
> 1. open Gallery app
> 2. turn it to landscape mode
> 3. long tap home button to enter Card View
> 
> *Expected result:
> I would expect to see a vertical card with a snapshot which is what I saw at
> Gallery app even if it is a landscape screenshot.
> 
> *Actual result:
> See a wired and zoomed snapshot at Gallery Card View.
> 
> *Env info:
> Build ID               20150201002504
> Gaia Revision          d6141fa3208f224393269e17c39d1fe53b7e6a05
> Gaia Date              2015-01-30 03:46:29
> Gecko Revision        
> https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f7414413e3a5
> Gecko Version          37.0a2
> Device Name            flame
> Firmware(Release)      4.4.2
> Firmware(Incremental)  eng.cltbld.20150201.043120
> Firmware Date          Sun Feb  1 04:31:31 EST 2015
> Bootloader             L1TC000118D0
Blocks: 1118390
blocking-b2g: --- → 2.2?
See Also: → 1120974
Whiteboard: [systemsfe]
blocking-b2g: 2.2? → 2.2+
Going to take a look.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Chris, please see the PR on bug 1128376. Maybe you and Etienne can talk it over? If he and you are ok with that approach, it would probably make this bug a dupe - though I've not tested all scenarios
Flags: needinfo?(chrislord.net)
ftr, I'm ok with the approach in bug 1128376 - I haven't gotten round to trying the patch yet, but if it doesn't already fix this, it'll make it easier.
Flags: needinfo?(chrislord.net)
Note: I just posted a patch on bug 1120974 that would solve this too. Waiting for an r+ before marking as duplicate though because we're still discussing the best approach.
Patch on bug 1120974 seems to fix this. It has r+, lets track it there. Duping.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120974
NI myself to verify this bug after bug 1120974 is resolved. Please also uplift that patch to v2.2, thanks. ;)
Flags: needinfo?(hcheng)
got the build on 2.2 now, close this bug.
Status: RESOLVED → VERIFIED
Flags: needinfo?(hcheng)
You need to log in before you can comment on or make changes to this bug.