Address autocomplete list is not sorted by usage frequency

RESOLVED DUPLICATE of bug 1134986

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 1134986
3 years ago
3 years ago

People

(Reporter: mpj.jonas, Unassigned)

Tracking

31 Branch
x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.94 Safari/537.36

Steps to reproduce:

When composing email and filling To field.


Actual results:

Autocomplete list suggested addresses in random order (barely used e-maisl on beginning, frequently used somewhere down the list)


Expected results:

Suggested e-mails in order by usage frequency. It worked in older versions but stop working after some upgrade (unfotunately I'm not sure which one)
(Reporter)

Updated

3 years ago
Summary: Address autocomplete lit is not sorted by usage frequency → Address autocomplete list is not sorted by usage frequency

Updated

3 years ago
Component: Address Book → Message Compose Window

Comment 1

3 years ago
We first list the best result by matching the start of words. If there's a tie, frequency is used to determine order.
(Reporter)

Comment 2

3 years ago
Well in my case it is not working lůike that.

For example for search "olga" i got:

koreckova.olga@...
olga.mitasova@...
olga.seda108@...
o.zelinkova@...
olga.mitasova@... <-- most used e-mail
cieslarovaolga@...

All of them match olga but order is wrong.

Comment 3

3 years ago
I think you listing that without the display names? You need to look at those too. For instance o.zelin... wouldn't match olga.
(Reporter)

Comment 4

3 years ago
Yes, I listing in without names. With names it looks like this:

Olga KOrečková <koreckova.olga@...>
olga.mitasova@...
olga.seda108@...
Olga Zelinková <o.zelinkova@...>
olga.mitasova@... <-- most used e-mail
cieslarovaolga@...

But it doesn't change fact that all of them match but order is wrong.

Comment 5

3 years ago
The first 5 seems would have the same score. It's not possible to see the PopularityIndex, but that's the order according to the code (implemented in bug 970456). Note that the popularityindex do not age, so it's it's an all-time-mailed-count kind of thing. Also note: number 2 and number 5 are the same in your listing (though I guess they may have different domain).
(Reporter)

Comment 6

3 years ago
To address on first place I sent only 1 e-mail few years back. To e-mail on 5th place I sent 5 to 20 e-mail a day.

Yes there is different domain for item 2 and item 5.

It looks to me that popularity index is either not used or somehow damaged.
I'm starting to wonder if we could just expose the popularityIndex as an editable field in card properties. That way, users can both check and correct the actual popularity of their cards which they claim are unpopular but still get toplisted, most likely because they are popular but users aren't aware.
Bug 1134986 is same, but clearer there
See Also: → bug 1134986

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1134986
You need to log in before you can comment on or make changes to this bug.