"leaving a Room" tone is played in Device B when user A tries to join a Room and a GSM call is already in progress in that device

RESOLVED FIXED

Status

Firefox OS
Gaia::Loop
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: oteo, Assigned: jaoo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Room1.1.1_Exploratory1][loop approved for 1.1.1][In 1.1.1])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
See 

Reproduced in Loop master Ç(it also happens in 1.1.1 branch)

Prerequisites:
Device A and B logged in Loop Mobile Client.
Device A has created and shared a Room with Deivce B.


STRs:
1. Device B joins to the room 
2. Device A makes a GSM call to Device C and Device C picks up the GSM call.
3. Device A taps on "home" button, taps on the room, taps on "Join" button.


Actual result:
Device B see  "You are the only one in the room" in the Room call screen all the time but a "leaving a Room" tone is played in Device B when user A tries to join that Room

Expected result:
No sound should be played, as User A has not entered in the Room, User B should not hear a "leaving" tone.
(Reporter)

Updated

3 years ago
Assignee: nobody → josea.olivera
Status: NEW → ASSIGNED
(Reporter)

Updated

3 years ago
Whiteboard: [Room1.1.1_TestRun1]
(Assignee)

Comment 2

3 years ago
Created attachment 8557941 [details] [review]
Pointer to Github PR https://github.com/mozilla-b2g/firefoxos-loop-client/pull/546
Attachment #8557941 - Flags: review?(borja.bugzilla)
(Reporter)

Updated

3 years ago
Whiteboard: [Room1.1.1_TestRun1] → [Room1.1.1_Exploratory1]
Attachment #8557941 - Flags: review?(borja.bugzilla) → review+
(Assignee)

Comment 3

3 years ago
Landed in master branch at:

https://github.com/mozilla-b2g/firefoxos-loop-client/commit/c397aa32d3c0692d1bc596f99adeff5cd026e52f
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [Room1.1.1_Exploratory1] → [Room1.1.1_Exploratory1][Not in 1.1.1]
(Reporter)

Comment 4

3 years ago
Tested and the issue is completely fixed. 
Low risk bug so giving the approval to 1.1.1 branch?

Jose Antonio, could you be so kind of uplifting the patch? and thanks a lot!
Flags: needinfo?(josea.olivera)
Whiteboard: [Room1.1.1_Exploratory1][Not in 1.1.1] → [Room1.1.1_Exploratory1][loop approved for 1.1.1][Not in 1.1.1]
(Assignee)

Comment 5

3 years ago
Landed in 1.1.1 branch at:

https://github.com/mozilla-b2g/firefoxos-loop-client/commit/75aa78f4641e10e82ad1cc02feb92a2c7d39dce3
Flags: needinfo?(josea.olivera)
Whiteboard: [Room1.1.1_Exploratory1][loop approved for 1.1.1][Not in 1.1.1] → [Room1.1.1_Exploratory1][loop approved for 1.1.1][In 1.1.1]
You need to log in before you can comment on or make changes to this bug.