Closed Bug 1128722 Opened 5 years ago Closed 5 years ago

Highlighting text and moving cursor all the way up off screen then back over the highlighted text causes everything except the text you highlighted to be selected on certain websites

Categories

(Core :: DOM: Selection, defect)

35 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla38
Tracking Status
firefox35 --- affected
firefox36 --- affected
firefox37 --- affected
firefox38 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: e383577, Assigned: mats)

References

Details

(Keywords: regression, testcase)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

1. Go to: http://en.wikipedia.org/wiki/Test_%28assessment%29
2. Highlight "Test (assessment)"
3. While the text is highlighted and you haven't released the cursor, move the cursor all the way up up off the screen then move the cursor back down to the text you highlighted.

This issue happens on most Wikipedia pages and I've seen it happen on some other websites. (Can't give specific names right now, sorry)



Actual results:

Everything is highlighted except the original text you highlighted.


Expected results:

Everything will no longer be highlighted except the original text you highlighted.
Summary: Highlighting text and moving cursor all the way up off screen causes everything to be selected on certain websites → Highlighting text and moving cursor all the way up off screen then back over the highlighted text causes everything except the text you highlighted to be selected on certain websites
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=643b371e51df&tochange=299911e6983b

Regressed by: Bug 739396
Blocks: 739396
Status: UNCONFIRMED → NEW
Component: Untriaged → Selection
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Keywords: testcase-wanted
Attached file reduced html
Step to reproduce:
1. Open attachment 8560836 [details]
2. Select "Wiki" by mouse
    i.e., left mouse down at "W" and drag to the right direction and do not released the left mouse button
3. Drag to the top direction until outside of content area
4. Drag to the bottom direction

Actual Results:
"pedia  bla bla..." is selected, but "Wiki" is selected

Expected Results:
"Wikipedia  bla bla..." should be selected
Thanks Alice, I really appreciate your help.
OS: Windows 7 → All
Hardware: x86_64 → All
Depends on: 1129078
QA Contact: mats
To fix this bug we also need the patches in bug 1129078.
Assignee: nobody → mats
Attachment #8563761 - Flags: review?(bugs)
Attached patch part 2, tests.Splinter Review
QA Contact: mats
Attachment #8563761 - Flags: review?(bugs) → review+
Duplicate of this bug: 1134588
I disabled the new tests added in this bug on OSX and re-landed:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6e751a9279da
https://hg.mozilla.org/integration/mozilla-inbound/rev/e6a5ac331b13
Flags: needinfo?(mats)
https://hg.mozilla.org/mozilla-central/rev/6e751a9279da
https://hg.mozilla.org/mozilla-central/rev/e6a5ac331b13
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
You need to log in before you can comment on or make changes to this bug.