-moz-user-select: none cause lost of the beginning of drag selection

RESOLVED DUPLICATE of bug 1128722

Status

()

--
major
RESOLVED DUPLICATE of bug 1128722
4 years ago
4 years ago

People

(Reporter: juliensoler, Unassigned)

Tracking

({regression})

35 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox35 affected, firefox36 affected, firefox37 affected, firefox38 affected, firefox-esr31 unaffected)

Details

Attachments

(1 attachment)

364 bytes, text/html
Details
(Reporter)

Description

4 years ago
Created attachment 8566470 [details]
test.html

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

Do a drag selection with some elements having the style "-moz-user-select: none". I made a minimal example.



Actual results:

The unselectable elements are not selected, so that's ok, but sometimes, the beginning of the selection is set at the end of the unselectable element. The same happened with keyboard selection.


Expected results:

The selection should always start at the place where the mouse were clicked and dragged.

Updated

4 years ago
Blocks: 739396
Component: Untriaged → Selection
Keywords: regression
Product: Firefox → Core

Updated

4 years ago
Status: UNCONFIRMED → NEW
status-firefox35: --- → affected
status-firefox36: --- → affected
status-firefox37: --- → affected
status-firefox38: --- → affected
status-firefox-esr31: --- → unaffected
Ever confirmed: true
(Reporter)

Updated

4 years ago
OS: Windows 8.1 → All
Hardware: x86_64 → All
(Reporter)

Comment 1

4 years ago
This bug is really annoying. When you want to copy/paste code from a site like StackOverflow for example, if you go to far, you have to start again your selection.
Severity: normal → major
Sorry about the regression.  Please test a Nightly build in a few days and let me know if
it works now. Thanks.
No longer blocks: 739396
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1128722
You need to log in before you can comment on or make changes to this bug.