[RTL] "No SIM inserted" message etc is misplaced for RTL languages

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: jfkthame, Assigned: jfkthame)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
STR: With no SIM installed, change language to Arabic, then pull down the Notification panel.

The Arabic version of the message

  No SIM inserted
  Insert a SIM to enable Usage

should be flush-right, but appears on the left-hand side of the screen, somewhat truncated at the edge.

I would post a screenshot, but am having trouble getting my current build to produce one. :(
(Assignee)

Comment 1

3 years ago
Also, the second line of this text (the Arabic rendering of "Insert a SIM to enable Usage") is clipped at the bottom, making some of the characters illegible. This happens because of the use of an overly-constrained line height in the CSS for the p.meta element.
(Assignee)

Comment 2

3 years ago
Created attachment 8558590 [details] [review]
[PR] fix the Cost Control widget rendering for RTL languages
Thanks for the patch Jonathan! Please request review from a system peer like :alive or :kgrandon.
Component: Gaia::Cost Control → Gaia::System
Flags: needinfo?(jfkthame)
Whiteboard: [systemsfe]
Duplicate of this bug: 1115054
(Assignee)

Comment 5

3 years ago
Comment on attachment 8558590 [details] [review]
[PR] fix the Cost Control widget rendering for RTL languages

Oops, I thought I'd flagged this for review already, but apparently not. Sorry for the delay.
Flags: needinfo?(jfkthame)
Attachment #8558590 - Flags: review?(kgrandon)
feature-b2g: --- → 2.2+
Assignee: nobody → jfkthame
Comment on attachment 8558590 [details] [review]
[PR] fix the Cost Control widget rendering for RTL languages

This seems to do the job for me, thanks!
Attachment #8558590 - Flags: review?(kgrandon) → review+
In master: https://github.com/mozilla-b2g/gaia/commit/be64e0a1412c1b8c40b7597c77ed16841bdb152f
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-master: --- → fixed
Resolution: --- → FIXED
Comment on attachment 8558590 [details] [review]
[PR] fix the Cost Control widget rendering for RTL languages

Requesting uplift for this RTL feature.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Implementation.
[User impact] if declined: Poor RTL experience when viewing the usage widget.
[Testing completed]: Manual.
[Risk to taking this patch] (and alternatives if risky): Simple styling change, so low risk.
[String changes made]: None.
Attachment #8558590 - Flags: approval-gaia-v2.2?(bbajaj)

Updated

3 years ago
Attachment #8558590 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/a17bcb9738beeb73ce1068c0b0817b51f1c84748
status-b2g-v2.2: --- → fixed
Target Milestone: --- → 2.2 S5 (6feb)
This issue is verified fixed on the latest Nightly 3.0 build but is not yet on the latest night 2.2 Build.  Will verify that one on another day.

Results: The "No Sim inserted" message is correctly on the right side and does not get truncated.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150206010204
Gaia: 94af4b42d2ace6c9f38f31de77240604fac68af1
Gecko: 7c5f187b65bf
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Environmental Variables:
Device: Flame 2.2
BuildID: 20150206002505
Gaia: a52999ce7f783177deb17e267bf003a53e6fde06
Gecko: 01446d5231ef
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
Jayme, assigning this to you so you can verify 2.2 on Monday.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(jmercado)
This issue is verified fixed on Fame 2.2.

Results:  The "No SIM inserted message is correctly on the right and is not cut off.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150209002504
Gaia: e827781324cbde91d2434b388f5dead3303a85ee
Gecko: 0552759956d3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
Flags: needinfo?(jmercado) → needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15475/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.