If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The screenshots are not listed in app details page on Tablet in landscape mode

VERIFIED FIXED in 2015-02-03

Status

Marketplace
Consumer Pages
P4
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: ValentinaP, Assigned: spasovski)

Tracking

Avenir
2015-02-03
x86_64
Android
Points:
---

Details

(Reporter)

Description

3 years ago
Steps to reproduce:
1. Load details page for any app in MP-dev on your Tablet in landscape mode
2. Observe screenshots section
 
Expected results:
There are no display or layout issues.

Actual results:
The screenshots are not displayed. An empty gray box appears above app description.

Notes/Issues:
This issue is not reproducing on desktop using Responsive Design View for 1280x800 px.
Verified on FF38 (Android 4.2.1).
Screenshot for this issue http://screencast.com/t/SiGDNSRT

Updated

3 years ago
Assignee: nobody → dspasovski
Priority: -- → P1
(Assignee)

Comment 1

3 years ago
Hi Valentina. I can't reproduce this using my nexus 7 android with FF38 (nightly) and the prod release. If the issue persists on your end could you find the dimensions of your screen size for me. You can do this by visiting http://whatsmyuseragent.com/ on the tablet in landscape - there is a chart a little down the page.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

3 years ago
(In reply to Davor Spasovski [:spasovski] from comment #1)
> Hi Valentina. I can't reproduce this using my nexus 7 android with FF38
> (nightly) and the prod release. If the issue persists on your end could you
> find the dimensions of your screen size for me. You can do this by visiting
> http://whatsmyuseragent.com/ on the tablet in landscape - there is a chart a
> little down the page.

I still can reproduce this issue on my Asus Transformer (Android 4.2.1) tablet in landscape mode in FF38 (Win 7). My tablet has 1280px x 752px.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 3

3 years ago
I can reproduce in FF38 Win7 using the following steps:
1. Open your nightly browser.
2. Pres ctrl-shift-m to open responsive design view and select the 800x1280 px preset.
3. Close the responsive design view.
4. Open the detail page for an app with just a single screenshot (i.e: https://marketplace-dev.allizom.org/app/facebook-1 )
5. Press ctrl-shift-m 

Screencast for the above flow: http://screencast.com/t/JJPza1mmkO
(Assignee)

Comment 4

3 years ago
This *should* address this specific flow scenario. The key was checking a single preview app.

https://github.com/mozilla/fireplace/commit/fffa751
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

3 years ago
(In reply to Davor Spasovski [:spasovski] from comment #4)
> This *should* address this specific flow scenario. The key was checking a
> single preview app.
> 
> https://github.com/mozilla/fireplace/commit/fffa751

My issue is still reproducing on my Asus Transformer tablet on MP-dev (Android 4.2.1), for apps that have one screenshot or more screenshots. Can you reproduce this?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 6

3 years ago
Also, the issue from comment #3 is still reproducing.
(Assignee)

Comment 7

3 years ago
https://github.com/mozilla/fireplace/pull/1009
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

3 years ago
I saw in the GitHub link that the issue from comment #3 was fixed. Posftfix screenshot http://screencast.com/t/VJRQyRJzP8.

But, the issue from comment #0 is still reproducing. 
I know that is a very restrictive issue (only on Android, only on tablet, only in landscape mode), but it is annoying not to see app screenshots (+ a big gray space) and to be forced to use the tablet in portrait mode. Let's find a way to fix this. Thanks!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
We're having a hard time reproducing this, so it's going to be tough to solve it in a timely fashion.
Priority: P1 → P4

Comment 10

3 years ago
Reproducible on Lenovo Yoga Tab 10 (Android 4.4.2);
(Assignee)

Comment 11

3 years ago
Can't repro this but the way previews get resized has been refactored - lets hope this works:

https://github.com/mozilla/fireplace/pull/1030
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

3 years ago
Nope, nothing has changed. The issue is still reproducing, unfortunately.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 13

3 years ago
Was this tested on -dev? The new previews work isn't on stage yet.
(Reporter)

Comment 14

3 years ago
This logged issue is fixed on MP-dev FF39(Android 4.2.1).
Another thing appears to be going wrong in the screenshots area. The section is cut in the right side. Issue is reproducing on desktop too. Are this related or should I file another bug? 
(see screencast: http://screencast.com/t/3mCoOcPyJ7)
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(dspasovski)
Resolution: --- → FIXED
(Assignee)

Comment 15

3 years ago
Someone on the team seems to have addressed the margin issue. Thanks for confirming the resolution of the original issue.
Flags: needinfo?(dspasovski)
(Reporter)

Comment 16

3 years ago
That's great. 
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.