Closed Bug 1129074 Opened 5 years ago Closed 5 years ago

Content view sometimes blank on load until restart

Categories

(Firefox for Android :: Toolbar, defect)

34 Branch
All
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1158309
Tracking Status
fennec 38+ ---

People

(Reporter: snorp, Assigned: esawin)

References

Details

(Keywords: steps-wanted)

Intended to be another clone of bug 1083173, but bugzilla seems busted.

Basically we still have problems with the gecko view sometimes appearing permanently blank (white), which persists until it is restarted.
Summary: Content view sometimes blank on load → Content view sometimes blank on load until restart
Keywords: steps-wanted
I've been able to reproduce this easily with a clean profile on latest Nightly.

Device:Sony Xperia Z2(Android 4.4.4)

STR:
1. Go to http://marketplace.firefox.com/
2. Install a webapp (e.g. Flappy Bird Lives)
3. Tap on Done after webapp is installed
4. Close Firefox
5. Tap on the home webapp and choose to open with Nightly, and immediately tap on the home button
6. Tap again on the webapp

Result:
Screen is blank

Note: This are STR pretty much the same as in https://bugzilla.mozilla.org/show_bug.cgi?id=1083173#c0, I think it depends on the timing of the actions performed
It's reproducing for me on Nexus 7. As mentioned, the timing is critical here, I have good chances for reproducing it by tapping the home button as fast as possible after launching the app and then letting the app (fail to) load in the background for a few seconds before activating it again.

This isn't reproducing as consistently as before (bug 1083173), so it's possible that we just eased a race condition with the previous fix or that we have regressed on something to re-introduce the race.
tracking-fennec: --- → ?
Assignee: nobody → esawin
tracking-fennec: ? → 38+
I think this started appearing more when bug 888482 landed.
This issue is caused when we receive and handle the Gecko:Ready event in GeckoApp before calling GeckoApp::initializeChrome, in which case geckoConnected would never be called on the layer view.

To fix this, we need to make sure the layer view is initialized before calling geckoConnected, or we need to keep the Gecko state and call geckoConnected after the layer view initialization.

This should have been fixed in bug 1158309.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1158309
You need to log in before you can comment on or make changes to this bug.