Closed Bug 1158309 Opened 5 years ago Closed 5 years ago

Exception handling message "Gecko:Ready"

Categories

(Firefox for Android :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 40
Tracking Status
firefox37 --- wontfix
firefox38 --- wontfix
firefox38.0.5 + wontfix
firefox39 + wontfix
firefox40 --- fixed

People

(Reporter: gbrown, Assigned: jchen)

References

Details

Attachments

(1 file)

Some failed test logs contain

12:02:08     INFO -  04-24 11:54:49.333 E/GeckoApp(  787): Exception handling message "Gecko:Ready":
12:02:08     INFO -  04-24 11:54:49.333 E/GeckoApp(  787): java.lang.NullPointerException
12:02:08     INFO -  04-24 11:54:49.333 E/GeckoApp(  787): 	at org.mozilla.gecko.GeckoApp.geckoConnected(GeckoApp.java:2387)
12:02:08     INFO -  04-24 11:54:49.333 E/GeckoApp(  787): 	at org.mozilla.gecko.GeckoApp.handleMessage(GeckoApp.java:667)
12:02:08     INFO -  04-24 11:54:49.333 E/GeckoApp(  787): 	at org.mozilla.gecko.BrowserApp.handleMessage(BrowserApp.java:1822)
12:02:08     INFO -  04-24 11:54:49.333 E/GeckoApp(  787): 	at org.mozilla.gecko.EventDispatcher.dispatchEvent(EventDispatcher.java:208)
12:02:08     INFO -  04-24 11:54:49.333 E/GeckoApp(  787): 	at org.mozilla.gecko.EventDispatcher.dispatchEvent(EventDispatcher.java:178)
12:02:08     INFO -  04-24 11:54:49.333 E/GeckoApp(  787): 	at org.mozilla.gecko.GeckoAppShell.handleGeckoMessage(GeckoAppShell.java:2253)
12:02:08     INFO -  04-24 11:54:49.333 E/GeckoApp(  787): 	at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)
12:02:08     INFO -  04-24 11:54:49.333 E/GeckoApp(  787): 	at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:382)
12:02:08     INFO -  04-24 11:54:49.333 E/GeckoApp(  787): 	at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:187)

For examples, see https://bugzilla.mozilla.org/show_bug.cgi?id=1054292#c1803 and https://bugzilla.mozilla.org/show_bug.cgi?id=1054292#c1804.
:jchen -- I'm pretty sure this is related to bug 1150693; can you have a look?
Flags: needinfo?(nchen)
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
This should fix the race condition. It's kind of gross that we need a focus hack to get tests to pass, but it was coincidence that we didn't need the hack before.
Attachment #8599486 - Flags: review?(snorp)
Comment on attachment 8599486 [details] [diff] [review]
Initialize LayerView sooner (v1)

Review of attachment 8599486 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/GeckoApp.java
@@ +1414,5 @@
>                  ((SurfaceView)mCameraView).getHolder().setType(SurfaceHolder.SURFACE_TYPE_PUSH_BUFFERS);
>              }
>          }
>  
> +        // XXX our editor tests require the GeckoView to have focus to pass, so we have to

I don't think the XXX adds anything :)
Attachment #8599486 - Flags: review?(snorp) → review+
https://hg.mozilla.org/mozilla-central/rev/7552ffb7bd0c
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
Duplicate of this bug: 1129074
[Tracking Requested - why for this release]: This is a bad bug. We should consider Aurora and maybe even 38.0.5. See bug 1129074 for how it manifests and https://input.mozilla.org/en-US/?q=white+or+blank&product=Firefox+for+Android&date_start=2015-02-04&selected=90d for user feedback that may be relevant.
Jim, can you provide an uplift request to mozilla release? (for 38.0.5beta)
We'd have to uplift both bug 1150693 and this bug. It's kind of risky...
Flags: needinfo?(nchen)
OK. Thanks.
Let it ride the train then!
Comment on attachment 8599486 [details] [diff] [review]
Initialize LayerView sooner (v1)

Approval Request Comment

[Feature/regressing bug #]: N/A

[User impact if declined]: This bug is a regression from bug 1150693. It should be uplifted together with bug 1150693.

[Describe test coverage new/current, TreeHerder]: m-c; locally

[Risks and why]: Same risk as bug 1150693

[String/UUID change made/needed]: None
Attachment #8599486 - Flags: approval-mozilla-beta?
Attachment #8599486 - Flags: approval-mozilla-aurora?
Comment on attachment 8599486 [details] [diff] [review]
Initialize LayerView sooner (v1)

This landed on m-c when it was still Gecko 40, so it doesn't need to land on Aurora.
Attachment #8599486 - Flags: approval-mozilla-aurora?
I'd like this to ride along with 40 unless it is definitely needed in beta along with bug 1150693.
Attachment #8599486 - Flags: approval-mozilla-beta?
Depends on: 1166309
Depends on: 1171510
You need to log in before you can comment on or make changes to this bug.