[RTL][Rocket Bar] Browser History and Google Search results are left-aligned.

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: ychung, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8558839 [details]
SearchResult.png

Description:
When the user types a keyword in the rocket bar, the "HISTORY" and "GOOGLE SEARCH" results are left-aligned.
   
Pre-requisite: The browser history is not empty.

Repro Steps:
1) Update a Flame device to BuildID: 20150203055641.
2) Set the device language in Arabic under Settings > Language.
3) Type in any letters in the rocket bar.
4) Observe the results under "HISTORY" and "GOOGLE SEARCH".

Actual:
The items are left-aligned.
  
Expected: 
The items are right-aligned.

Device: Flame Master (319mb, full flash)
Build ID: 20150203055641
Gaia: ae5a1580da948c3b9f93528146b007fc4f6a712b
Gecko: ae5d04409cd9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
  
Repro frequency: 100%
See attached: screenshot
(Reporter)

Comment 1

4 years ago
"HISTORY" and "GOOGLE SEARCH" results are new feature in Flame 3.0. Unable to reproduce this issue on Flame 2.2.

Device: Flame 2.2 (319mb, full flash)
Build ID: 20150203002504
Gaia: cd62ff9fe199fb43920ba27bd5fdbc5c311016fc
Gecko: 11d93135c678
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
triage: P3, this is not a problem on 2.2.
feature-b2g: --- → 3.0?
status-b2g-v2.2: --- → unaffected
Priority: -- → P3
Created attachment 8565271 [details]
Flame2.2.png

Hi Dylan,

The new feature have been built in Flame 2.2, and the issue still exist on Flame 2.2.
See the attachment: Flame2.2.png.

Flame 2.2 build:
Build ID               20150216002503
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/62c80c92b39e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.040540
Firmware Date          Mon Feb 16 04:05:52 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(doliver)
status-b2g-v2.2: unaffected → affected
(Reporter)

Comment 4

4 years ago
Created attachment 8566678 [details]
LongSearchResult.png

It looks like the browser history and search result are now right-aligned. However, the search icons are still located at the left side of the screen, causing an overlapping issue with a long search result.

Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150219010228
Gaia: 620aecfde85a8b093247837c55de2708e22be1e1
Gecko: 360b5f211180
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150219002504
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: 159a3907b959
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Clearing priority to get this back in the triage queue with new information from comment #4.
feature-b2g: 3.0? → ---
Flags: needinfo?(doliver)
Priority: P3 → P2
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15445/
Flags: in-moztrap+
No longer blocks: 1151067
Also occurs in the browser app too.
launch browser app and take a look at the history.
Created attachment 8612752 [details]
Cannot be reproduced.png

This Problem cannot be reproduced on latest build of Flame 2.2/3.0, N5 2.2/3.0 by the STR in comment 0 and the case in comment 4. The result items under "HISTORY" and "GOOGLE SEARCH" are right-aligned and the magnifying glass icons are located at the right side of the screen now.
If anyone can repro it, reopen again.

See attachment: Cannot be reproduced.png

Device: 
Flame 2.2 Build ID 20150528162502
Flame 3.0 Build ID 20150528160205
Nexus5 2.2 Build ID 20150528162502
Nexus5_3.0 Build ID 20150528160205
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.