[RTL][Rocket Bar] Search history URL is being truncated differently than the same URL in card view

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: KTucker, Assigned: sfoster)

Tracking

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(5 attachments)

Description:
The user will notice a search history result will be truncated on the left under the Rocketbar but the same URL will be truncated on the right in card view. 

Search history result under the rocketbar:

...//www.google.com/search?q=happy

In card view, the user will see:

www.google.com/search...
   
Repro Steps:
1) Update a Flame device to BuildID: 20150403010203
2) Set the device language in Arabic under Settings > Language.
3) Perform a search for "Happy" in the rocketbar. 
4) After the webpage opens up, hold down the "Home" button on the dut to enter card view.
5) Look at the URL for the search above the webpage card.
6) Tap the "Home" button on the dut to return to the homescreen.
7) Tap on the "Rocketbar" on the homescreen and start entering the search term "Happy" again. 
8) Look at the URL under the search history.

Actual:
The url under search history is truncated differently that the same url in card view.
  
Expected: 
Both URLs are truncated in the same way.

Environmental Variables:
Device: Flame 3.0(Full Flash)(KK)(319mb)
Build ID: 20150403010203
Gaia: 7969b367a7da62877c3a24a26d3cb5fda89d766c
Gecko: 70a113676b21
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
  
Repro frequency: 100%
See attached: screenshots
This issue also occurs on Flame 2.2

Device: Flame 2.2 (Full Flash)(KK)(319mb)
Build ID: 20150401002624
Gaia: 8b3086ad3963f1707e2bee9094baccafffe161c4
Gecko: 20b67213a047
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
No longer depends on: 1129234
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing]
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
Blocks: 1151132
No longer blocks: 1151132
Assignee

Comment 3

4 years ago
Nominating. I'll take a look at this - its very likely a similar issue to bug 1151925.
Assignee: nobody → sfoster
blocking-b2g: --- → 2.2?
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
Target Milestone: --- → 2.2 S9 (3apr)
Assignee

Comment 4

4 years ago
Francis, can you just confirm that this is what we are looking for with bidi or LTR content in a RTL UI? I've got both title and url right-aligned here in RTL. Truncation should follow language direction, so we'll see the ellipsis on the right for LTR and predominately LTR bidi content, and on the left for RTL content. We also see the start of the url here like in card view, instead of the end (current behavior on master, 2.2)
Attachment #8591903 - Flags: ui-review?(fdjabri)
This looks correct to me. If a word is from a LTR language, it should read LTR and we should truncate accordingly.
Attachment #8591903 - Flags: ui-review?(fdjabri) → ui-review+
Steph, would you mind taking a look just to confirm?
Flags: needinfo?(swilkes)
blocking-b2g: 2.2? → 2.2+
Assignee

Comment 7

4 years ago
(In reply to Francis Djabri [:djabber] from comment #6)
> Steph, would you mind taking a look just to confirm?

I have a memory of this alignment issue coming up - perhaps with SMS - and IIRC we decided to right-align lists like this in RTL, regardless of their locale/direction. Does that sound right? I.e. the rocketbar history list would be ragged-left for RTL, ragged-right (left-aligned) for LTR.

Comment 8

4 years ago
Francis is correct and this is covered in the spec document (both alignment and truncation for both RTL and LTR languages are in the spec).
Flags: needinfo?(swilkes)
Comment on attachment 8593121 [details] [review]
[gaia] sfoster:search-history-url-rtl-bug-1151067 > mozilla-b2g:master

More RTL/bidi tweaks. Where we know we are displaying a URL, I added the 'ltr' dir attribute. It helps, but its a stop-gap and hopefully we can solve the URL display thing upstream eventually.  

BTW, I ran into some problems while testing this where I wasn't getting icons or titles for new places entries - always the URL. I didn't get to the bottom of it or narrow down STR yet. Could it be a side-effect of switching between languages? Use of non-ascii titles? Anyhow I'm pretty certain this is not introduced by this patch and will file it if I can repro on master 

FYI: https://ar.wikipedia.org/, http://aljazeera.net are a couple of arabic languages I was testing with
Attachment #8593121 - Flags: review?(kgrandon)
Comment on attachment 8593121 [details] [review]
[gaia] sfoster:search-history-url-rtl-bug-1151067 > mozilla-b2g:master

Going to flip this review over to Dale if that's alright as my queue is starting to backup and I don't want you to wait too long. Thanks.
Attachment #8593121 - Flags: review?(kgrandon) → review?(dale)
Comment on attachment 8593121 [details] [review]
[gaia] sfoster:search-history-url-rtl-bug-1151067 > mozilla-b2g:master

This looks good to me, cheers
Attachment #8593121 - Flags: review?(dale) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29534

The pull request could not be applied to the integration branch. Please try again after current integration is complete. You may need to rebase your branch against the target branch.
(In reply to Autolander from comment #13)
> https://github.com/mozilla-b2g/gaia/pull/29534
> 
> The pull request could not be applied to the integration branch. Please try
> again after current integration is complete. You may need to rebase your
> branch against the target branch.

Trying again..
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Please request Gaia v2.2 approval on this patch when you get a chance.
Flags: needinfo?(sfoster)
Target Milestone: 2.2 S9 (3apr) → 2.2 S10 (17apr)
Comment on attachment 8593121 [details] [review]
[gaia] sfoster:search-history-url-rtl-bug-1151067 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): RTL in Search & New Tab 
[User impact] if declined: Icon labels, search and history results can get truncated and ellipsized from wrong end
[Testing completed]: Tested on device, with both en-us and ar default locales
[Risk to taking this patch] (and alternatives if risky): Low risk, limited CSS/markup changes confined to search app
[String changes made]: None
Flags: needinfo?(sfoster)
Attachment #8593121 - Flags: approval-gaia-v2.2?
Blocks: 1155459
No longer blocks: 1155459
Attachment #8593121 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Comment 19

4 years ago
Posted image verify_pass.png
This issus has been verified passed on latest build of Flame2.2/3.0 with the same steps in comment 0.
See attachment:verify_pass.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150419002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.040848
Firmware Date          Sun Apr 19 04:08:59 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (pass)
Build ID               20150419160202
Gaia Revision          c6b04efa0f31a584e6ee0a46dd2b64c1e3c29adc
Gaia Date              2015-04-17 21:10:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a32e3b93c8d8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.193329
Firmware Date          Sun Apr 19 19:33:40 EDT 2015
Bootloader             L1TC000118D0

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.