when the "find plugin" dialog comes up, browser crashes

RESOLVED DUPLICATE of bug 98892

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 98892
16 years ago
15 years ago

People

(Reporter: Jim Dunn, Assigned: Philip K. Warren)

Tracking

Trunk
Other
AIX
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
when you go to this site, the dialog finder pops-up and
this crashes the browser.  here is the traceback
ptrgl._ptrgl() at 0xda41af50
Reflow__13nsObjectFrameFP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi(0x20afe038,
0x20a23598, 0x2ff1e010, 0x2ff1df40, 0x2ff1e5ac) at 0xda68fbe8
ReflowFrame__12nsLineLayoutFP8nsIFramePP8nsIFrameRUiP19nsHTMLReflowMetricsRi(0x2ff1e6f0,
0x20afe038, 0x2ff1e2a8, 0x2ff1e5ac, 0x0, 0x2ff1e16c) at 0xda49447c
ReflowInlineFrame__13nsInlineFrameFP14nsIPresContextRC17nsHTMLReflowStateRQ2_13nsInlineFrame17InlineReflowStateP8nsIFrameRUi(0x20afdcf0,
0x20a23598, 0x2ff1e370, 0x2ff1e2a8, 0x20afe038, 0x2ff1e5ac) at 0xda5800c0
ReflowFrames__13nsInlineFrameFP14nsIPresContextRC17nsHTMLReflowStateRQ2_13nsInlineFrame17InlineReflowStateR19nsHTMLReflowMetricsRUi(0x20afdcf0,
0x20a23598, 0x2ff1e370, 0x2ff1e2a8, 0x2ff1e440, 0x2ff1e5ac) at 0xda57f928
Reflow__13nsInlineFrameFP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi(0x20afdcf0,
0x20a23598, 0x2ff1e440, 0x2ff1e370, 0x2ff1e5ac) at 0xda57f5b4
ReflowFrame__12nsLineLayoutFP8nsIFramePP8nsIFrameRUiP19nsHTMLReflowMetricsRi(0x2ff1e6f0,
0x20afdcf0, 0x2ff1eed0, 0x2ff1e5ac, 0x0, 0x2ff1e5b0) at 0xda49447c
ReflowInlineFrame__12nsBlockFrameFR18nsBlockReflowStateR12nsLineLayout19nsLineList_iteratorP8nsIFramePUc(0x20adef5c,
0x2ff1ee58, 0x2ff1e6f0, 0x20afdb48, 0x20afdcf0, 0x2ff1e660) at 0xda42744c
DoReflowInlineFrames__12nsBlockFrameFR18nsBlockReflowStateR12nsLineLayout19nsLineList_iteratorPiPUciT6(0x20adef5c,
0x2ff1ee58, 0x2ff1e6f0, 0x20afdb48, 0x2ff1ed24, 0x2ff1ebb4, 0x0, 0x1) at 0xda426ec8
DoReflowInlineFramesAuto__12nsBlockFrameFR18nsBlockReflowState19nsLineList_iteratorPiPUciT5(0x20adef5c,
0x2ff1ee58, 0x20afdb48, 0x2ff1ed24, 0x2ff1ebb4, 0x0, 0x1) at 0xda426b3c
ReflowInlineFrames__12nsBlockFrameFR18nsBlockReflowState19nsLineList_iteratorPiiT4(0x20adef5c,
0x2ff1ee58, 0x20afdb48, 0x2ff1ed24, 0x1, 0x0) at 0xda424470
ReflowLine__12nsBlockFrameFR18nsBlockReflowState19nsLineList_iteratorPii(0x20adef5c,
0x2ff1ee58, 0x20afdb48, 0x2ff1ed24, 0x1) at 0xda422af4
ReflowDirtyLines__12nsBlockFrameFR18nsBlockReflowState(0x20adef5c, 0x2ff1ee58)
at 0xda41f4cc
Reflow__12nsBlockFrameFP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi(0x20adef5c,
0x20a23598, 0x2ff1f4e8, 0x2ff1f378, 0x2ff1f638) at 0xda41d734
DoReflowBlock__20nsBlockReflowContextFR17nsHTMLReflowState14nsReflowReasonP8nsIFrameRC6nsRectiR18nsCollapsingMarginT5R8nsMarginRUi(0x2ff1f4a0,
0x2ff1f378, 0x4, 0x20adef5c, 0x2ff1f628, 0x1, 0x2ff1fa64, 0x0) at 0xda4c8ecc
ReflowBlock__20nsBlockReflowContextFP8nsIFrameRC6nsRectiR18nsCollapsingMarginT3R8nsMarginRUi(0x2ff1f4a0,
0x20adef5c, 0x2ff1f628, 0x1, 0x2ff1fa64, 0x0, 0x2ff1f640, 0x2ff1f638) at 0xda4c88d8
ReflowBlockFrame__12nsBlockFrameFR18nsBlockReflowState19nsLineList_iteratorPi(0x20ade920,
0x2ff1f9e8, 0x20afd990, 0x2ff1f8b4) at 0xda423a60
ReflowLine__12nsBlockFrameFR18nsBlockReflowState19nsLineList_iteratorPii(0x20ade920,
0x2ff1f9e8, 0x20afd990, 0x2ff1f8b4, 0x1) at 0xda422624
ReflowDirtyLines__12nsBlockFrameFR18nsBlockReflowState(0x20ade920, 0x2ff1f9e8)
at 0xda41f4cc
Reflow__12nsBlockFrameFP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi(0x20ade920,
0x20a23598, 0x2ff20078, 0x2ff1ff08, 0x2ff201c8) at 0xda41d734
DoReflowBlock__20nsBlockReflowContextFR17nsHTMLReflowState14nsReflowReasonP8nsIFrameRC6nsRectiR18nsCollapsingMarginT5R8nsMarginRUi(0x2ff20030,
0x2ff1ff08, 0x1, 0x20ade920, 0x2ff201b8, 0x1, 0x2ff205f4, 0x1) at 0xda4c8ecc
ReflowBlock__20nsBlockReflowContextFP8nsIFrameRC6nsRectiR18nsCollapsingMarginT3R8nsMarginRUi(0x2ff20030,
0x20ade920, 0x2ff201b8, 0x1, 0x2ff205f4, 0x1, 0x2ff201d0, 0x2ff201c8) at 0xda4c88d8
ReflowBlockFrame__12nsBlockFrameFR18nsBlockReflowState19nsLineList_iteratorPi(0x20ade5f8,
0x2ff20578, 0x20adeafc, 0x2ff20444) at 0xda423a60
ReflowLine__12nsBlockFrameFR18nsBlockReflowState19nsLineList_iteratorPii(0x20ade5f8,
0x2ff20578, 0x20adeafc, 0x2ff20444, 0x1) at 0xda422624
ReflowDirtyLines__12nsBlockFrameFR18nsBlockReflowState(0x20ade5f8, 0x2ff20578)
at 0xda41f4cc
Reflow__12nsBlockFrameFP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi(0x20ade5f8,
0x20a23598, 0x2ff20978, 0x2ff209b8, 0x2ff20e08) at 0xda41d734
ReflowChild__16nsContainerFrameFP8nsIFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateiT5UiRUi(0x20aa71cc,
0x20ade5f8, 0x20a23598, 0x2ff20978, 0x2ff209b8, 0x0, 0x0, 0x0) at 0xda439b28
Reflow__11CanvasFrameFP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi(0x20aa71cc,
0x20a23598, 0x2ff20e10, 0x2ff20c48, 0x2ff20e08) at 0xda6447a8
Reflow__19nsBoxToBlockAdaptorFR16nsBoxLayoutStateP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUiiN46(0x20ade55c,
0x2ff21420, 0x20a23598, 0x2ff20e10, 0x2ff21620, 0x2ff20e08, 0x0, 0x0) at 0xda5dedac
DoLayout__19nsBoxToBlockAdaptorFR16nsBoxLayoutState(0x20ade55c, 0x2ff21420) at
0xda5de350
Layout__5nsBoxFR16nsBoxLayoutState(0x20ade55c, 0x2ff21420) at 0xda5d8da0
DoLayout__16nsScrollBoxFrameFR16nsBoxLayoutState(0x20aa7524, 0x2ff21420) at
0xda5f17bc
Layout__5nsBoxFR16nsBoxLayoutState(0x20aa7558, 0x2ff21420) at 0xda5d8da0
LayoutChildAt__14nsContainerBoxFR16nsBoxLayoutStateP6nsIBoxRC6nsRect(0x2ff21420,
0x20aa7558, 0x2ff21278) at 0xda5d1ac8
LayoutBox__21nsGfxScrollFrameInnerFR16nsBoxLayoutStateP6nsIBoxRC6nsRect(0x20aa5ce8,
0x2ff21420, 0x20aa7558, 0x2ff21278) at 0xda5ea4e4
Layout__21nsGfxScrollFrameInnerFR16nsBoxLayoutState(0x20aa5ce8, 0x2ff21420) at
0xda5ea878
DoLayout__16nsGfxScrollFrameFR16nsBoxLayoutState(0x20aa72cc, 0x2ff21420) at
0xda5ea5a4
Layout__5nsBoxFR16nsBoxLayoutState(0x20aa7300, 0x2ff21420) at 0xda5d8da0
Reflow__10nsBoxFrameFP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi(0x20aa72cc,
0x20a23598, 0x2ff215e0, 0x2ff21620, 0x2ff217f0) at 0xda5c6eb4
Reflow__16nsGfxScrollFrameFP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi(0x20aa72cc,
0x20a23598, 0x2ff215e0, 0x2ff21620, 0x2ff217f0) at 0xda5e8dd8
ReflowChild__16nsContainerFrameFP8nsIFrameP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateiT5UiRUi(0x20aa7194,
0x20aa72cc, 0x20a23598, 0x2ff215e0, 0x2ff21620, 0x0, 0x0, 0x0) at 0xda439b28
Reflow__13ViewportFrameFP14nsIPresContextR19nsHTMLReflowMetricsRC17nsHTMLReflowStateRUi(0x20aa7194,
0x20a23598, 0x2ff218b0, 0x2ff21738, 0x2ff217f0) at 0xda63f880
Dispatch__19nsHTMLReflowCommandFP14nsIPresContextR19nsHTMLReflowMetricsRC6nsSizeR19nsIRenderingContext(0x209b49c8,
0x20a23598, 0x2ff218b0, 0x2ff218f0, 0x208fa478) at 0xda4799a4
ProcessReflowCommand__9PresShellFR11nsVoidArrayiR19nsHTMLReflowMetricsR6nsSizeR19nsIRenderingContext(0x20a99808,
0x20a99854, 0x1, 0x2ff218b0, 0x2ff218f0, 0x208fa478) at 0xda8121a0
ProcessReflowCommands__9PresShellFi(0x20a99808, 0x1) at 0xda80ea98
HandleEvent__11ReflowEventFv(0x209b9218) at 0xda817cb4
HandlePLEvent__FP11ReflowEvent(0x209b9218) at 0xda81203c
PL_HandleEvent(0x209b9218) at 0xd8ca6ef0
PL_ProcessPendingEvents(0x20028a98) at 0xd8ca7400
ProcessPendingEvents__16nsEventQueueImplFv(0x20028a48) at 0xd8ca43f0
event_processor_callback__FPvi17GdkInputCondition(0x20028a48, 0x5, 0x1) at
0xd9a48b74
our_gdk_io_invoke__FP11_GIOChannel12GIOConditionPv(0x204d6958, 0x1, 0x20373708)
at 0xd9a49270
g_io_unix_dispatch() at 0xd23cc99c
g_main_dispatch() at 0xd23cd5fc
g_main_iterate() at 0xd23cd3c4
g_main_run() at 0xd23ce56c
gtk_main() at 0xd21ac8ec
Run__10nsAppShellFv(0x2002c568) at 0xd9a486a0
Run__17nsAppShellServiceFv(0x2002b8c8) at 0xdae86da8
main1__FiPPcP11nsISupports(0x2, 0x2ff220a0, 0x0) at 0x1000246c
main(0x2, 0x2ff220a0) at 0x10001330
(Reporter)

Comment 1

16 years ago
updating
Status: NEW → ASSIGNED
QA Contact: shrir → jdunn

Comment 2

16 years ago
Jim, 

this native plugin library is being replaced with an XP XBL one in bug 83754 so
this may disappear from Mozilla soon.

However, the crash will still be in this old version of the default plugin on AIX.
Depends on: 83754
(Assignee)

Comment 3

16 years ago
Reassigning bug to me.
Assignee: jdunn → pkw
Status: ASSIGNED → NEW
(Assignee)

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 98892 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.