Enabling bluetooth in settings doesn't work

RESOLVED DUPLICATE of bug 1124983

Status

Firefox OS
Bluetooth
--
major
RESOLVED DUPLICATE of bug 1124983
3 years ago
3 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

({regression})

unspecified
x86
Mac OS X
regression

Firefox Tracking Flags

(blocking-b2g:2.5?)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
[Blocking Requested - why for this release]:

Reproduced with engineering build on the Flame:
Gaia-Rev        dfebaaa8aab43470f482d09d71137bab840c3ae9
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/0c2f7434c325
Build-ID        20150204010225
Version         38.0a1
Device-Name     flame

Steps to reproduce:
- Go to Settings
- Tap on Bluetooth to go to Bluetooth
- Tap on the Bluetooth checkbox to turn it on

Expected result:
- Bluetooth checkbox checked and bluetooth devices in the area found

Actual result:
- Bluetooth checkbox stays grayish blue and no bluetooth devices in the area are found
(Reporter)

Updated

3 years ago
Blocks: 1118219
(Reporter)

Comment 1

3 years ago
This used to work when Softvision carried out 02/03/2015 Flame KK v18D Gaia-ui Automation v2.2 Mozilla RIL Full Flash Build 41/45 smoketests (test_settings_bluetooth.py gaia-ui test would catch this).
Also, I verified on a phone from Marcia (in a user build) that it used to work in a build from 2 days ago, but not in today's build.
(Reporter)

Comment 2

3 years ago
Hrm, this doesn't seem to work for me with https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-flame-kk-eng/2015/02/2015-02-01-01-02-17/ from ./flash_pvt.py
(Reporter)

Comment 3

3 years ago
Ok, Johan tested this too on a device with today's master build and he can't reproduce this issue at all.
(Reporter)

Comment 4

3 years ago
Created attachment 8559517 [details]
logcat.txt

This is a logcat with latest master build on my Flame with bluetooth debugging enabled in developer settings.

I did the str in this bug, then I closed the settings app, reopened the settings app, then tapped on the checkbox again (to disable bluetooth), then tapped on the checkbox again (to enable bluetooth).
The checkbox is then checked, but no devices in the area can be found at all.
(Reporter)

Comment 5

3 years ago
Teri, do you know why bluetooth doesn't work on my Flame device and on Marcia's Flame device also and why it is working on other devices?
Flags: needinfo?(twen)
(Reporter)

Updated

3 years ago
Flags: needinfo?(twen)
:mwargers, you need to full flash your phone using the Taiwan QA flashing tool as follows:
https://github.com/Mozilla-TWQA/B2G-flash-tool
$ ./flash_pvt -w
Flashing paramaters: flame-kk, mozilla-central, User, images, latest.

The key is 'images' to get the bluetooth-related changes on your phone.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1124983
(Reporter)

Updated

3 years ago
No longer blocks: 1118219
(Reporter)

Comment 7

3 years ago
Thanks Parul.
It turned out something was changed in the base image for bluetooth and gecko made use of that new change. If you then don't update your base image and only gaia+gecko, bluetooth stops working.
You need to log in before you can comment on or make changes to this bug.