[Music] The Track Number for songs is shown the different playlists leading to confusing UX.

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: hub)

Tracking

({regression})

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Description:
Some music tracks come with track # information. It is primarily used to order the tracks when playing an entire album. The track # appears as a number to the left of the track name. When looking at the Playlists (Highest rated, Recently added, Most played, Lease played)  The track #'s are shown instead of any sort of listing value. This is confusing UX and might even be leading to propagating the wrong songs into the lists. 

Repro Pre-req: Have songs on your device (best if you have a whole album)

Repro Steps:
1) Update a Flame to 20150204010225
2) Launch Music 
3) Select Playlists (2nd icon at bottom)
4) Select Most Played (for example)

Actual:
Track #'s are listed to the left of the song name instead of position # (relative to the listing)

Expected:
Track #'s will not show here - assigned numbers to list the relevant songs in order should be here.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150204010225
Gaia: dfebaaa8aab43470f482d09d71137bab840c3ae9
Gecko: 0c2f7434c325
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Repro frequency: 5/5
See attached: logcat, Video: http://youtu.be/R1QHFvwvaaU

------------------------------------------------------------------------------------------
This issue DOES reproduce in 2.2 (v18d-1), 2.2 (v18d)

Device: Flame 2.2 (KK - Nightly - Full Flash)
Build ID: 20150202002507
Gaia: d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko: be206fa2fb60
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18d-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.2 (KK - Nightly - Full-Flashed)
Build ID: 20150202002507
Gaia: d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko: be206fa2fb60
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18d
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

---------------------------------------------------------------------------------------
This issue does NOT reproduce in 2.1 or 2.0

Actual Results: Songs are listed in an order relevant to the playlist from 1-30 out to the left.

Device: Flame 2.1 (KK - Nightly - Full-Flashed)
Build ID: 20150202001432
Gaia: 63f291df9b9ad8498fb8fc7fb8bf070524406a5c
Gecko: 70b8982a523d
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0 (KK - Nightly - Full-Flashed)
Build ID: 20150202000205
Gaia: 2989f2b2bd12fcc0e9c017d2db766e76a55873b8
Gecko: b961877cacba
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
This looks like it may have been an intentional change, NI on component area owner for nomination decision and assignment.
Flags: needinfo?(pbylenga) → needinfo?(npark)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
It is strictly an appearance issue, but it does look quite odd to see the numberings on the list that are not relevant for the selected list.  Hema, is this an intentional change?
Flags: needinfo?(npark) → needinfo?(hkoka)
(Assignee)

Comment 3

4 years ago
Is that a side effect of bug 796305?

Comment 4

4 years ago
The fixes that went in related to this are for sorting the songs by the track number (https://bugzilla.mozilla.org/show_bug.cgi?id=796305) and displaying the track number when viewing songs in a single album (https://bugzilla.mozilla.org/show_bug.cgi?id=841977)

The issue reported seems to be for the cases of song lists from multi-album view (For ex: most played etc.) Seems like a missed side effect when fixing those bugs. For those views, showing track numbers does not make sense instead just a sequential list numbering. Flagging Rob/Jacqueline for feedback.

Assigning to Hub for the fix.
Assignee: nobody → hub
Flags: needinfo?(rmacdonald)
Flags: needinfo?(jsavory)
Flags: needinfo?(hkoka)
(Assignee)

Comment 5

4 years ago
oops.
I agree with Hema here, the track number ordering could definitely be confusing to the user. Returning to a sequential list numbering will clear up any confusion within the playlists.
Flags: needinfo?(rmacdonald)
Flags: needinfo?(jsavory)
(Assignee)

Comment 7

4 years ago
So shall we block for 2.2?
blocking-b2g: --- → 2.2?

Comment 8

4 years ago
Blocking Reason: Common scenario with viewing song lists from multi-album. If the user sees jumbled up numbers, it creates a pretty bad experience. Hence blocking. 

Hub,

Please fix it and ask for approval to uplift into 2.2 (assuming the risk from the fix is low)

Thanks a bunch!
Hema
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 10

4 years ago
Comment on attachment 8563642 [details] [review]
[gaia] hfiguiere:bug1179708-playlist-track-index > mozilla-b2g:master

Includes integration tests.
Attachment #8563642 - Flags: review?(dkuo)
(Assignee)

Comment 11

4 years ago
Comment on attachment 8563642 [details] [review]
[gaia] hfiguiere:bug1179708-playlist-track-index > mozilla-b2g:master

Switching reviewer to Jim. Thanks !
Attachment #8563642 - Flags: review?(dkuo) → review?(squibblyflabbetydoo)
(Assignee)

Updated

4 years ago
Blocks: 1122084
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
Comment on attachment 8563642 [details] [review]
[gaia] hfiguiere:bug1179708-playlist-track-index > mozilla-b2g:master

Overall this seems good, I suppose. It makes me wonder what we should do about user-defined playlists, but we can address that when we support them.
Attachment #8563642 - Flags: review?(squibblyflabbetydoo) → review+
(Assignee)

Comment 13

4 years ago
I think the user defined playlists will get indexes.

Updated the pull request to take the comment into account.
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 15

4 years ago
Comment on attachment 8563642 [details] [review]
[gaia] hfiguiere:bug1179708-playlist-track-index > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):  see comment 3 and comment 4
[User impact] if declined: not as good UX
[Testing completed]: automatic testing included.
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8563642 - Flags: approval-gaia-v2.2?(bbajaj)
(Assignee)

Updated

4 years ago
Flags: in-testsuite+
Attachment #8563642 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual results: The numbers in a playlist are related to the position of that song in the playlist and not its track list for its album.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150309010232
Gaia: fea83511df9ccba64259346bc02ebf2c417a12c2
Gecko: eab4a81e4457
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150309002506
Gaia: 166491b92278dc9e648f8d49ab02d9ca00d74421
Gecko: 91b7aa6a3243
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.