Closed Bug 1129831 Opened 6 years ago Closed 6 years ago

[FFOS2.0][Woodduck][GCF][STK]cause tag not fond on event download: browser termination

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0M+, b2g-v2.0 wontfix, b2g-v2.0M fixed, b2g-v2.1 fixed, b2g-v2.1S fixed, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S6 (20feb)
blocking-b2g 2.0M+
Tracking Status
b2g-v2.0 --- wontfix
b2g-v2.0M --- fixed
b2g-v2.1 --- fixed
b2g-v2.1S --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: pengfei.huang.hz, Assigned: selee)

References

Details

Attachments

(3 files)

DEFECT DESCRIPTION:[GCF][STK]cause tag not fond on event download: browser
termination

 REPRODUCING PROCEDURES:
1. Load a simcard to the phone which can send "eventlist: browser termination";
2. Execute TC 27.22.7.9.1/1, cause tag not fond on event download: browser
termination.--ko


 EXPECTED BEHAVIOUR:
2. Execute TC 27.22.7.9.1/1, cause tag should be ok on event download: browser
termination.

details please refer the log.


 ASSOCIATE SPECIFICATION:

 TEST PLAN REFERENCE:

 TOOLS AND PLATFORMS USED:

 USER IMPACT:

 REPRODUCING RATE:

 For FT PR, Please list reference mobile's behavior:
Attached file Tag_missing.zip
Hi Mozilla,
  Per mail discuss, the envelope of "Browser Termination" event lack the tag "Browser Termination cause" which is mandatory. 
02-04 11:26:50.902   574   585 D use-Rlog/RLOG-AT: AT+STKENV="D60799010882028281"
  D6 ---> EVENT DOWNLOAD Tag
  07 ---> Length
  9901  --->Device identify
  0882028281   ---->Event List
  There are two type of cause defined in ril_const.
// Browser Termination Cause.
this.STK_BROWSER_TERMINATION_CAUSE_USER = 0x00;
this.STK_BROWSER_TERMINATION_CAUSE_ERROR = 0x01;
  
  and ril_worker has implemented the "Browser Termination cause" tag at sendICCEnvelopeCommand.
      GsmPDUHelper.writeHexOctet(options.terminationCause);

  Hence, we need to add options.terminationCause when send stkEventDownload. The problem is there is no related value for STK_BROWSER_TERMINATION_CAUSE_USER and STK_BROWSER_TERMINATION_CAUSE_ERROR at gaia. The other problem is how to confirm whether the browser is closed normally.
  Thanks.
Hi Sean,
Could you please help to check the problem? Thanks!
blocking-b2g: --- → 2.0M?
Flags: needinfo?(selee)
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Reference:

@ETSI TS 102 223 V11.3.0 (2014-06)
7.5.9.2 Structure of ENVELOPE (EVENT DOWNLOAD - Browser termination)
8.51 Browser termination cause

00 = User Termination
01 = Error Termination
Flags: needinfo?(selee)
Hi Pengfei,

Please try the trail patch. Thank you.

diff --git a/apps/system/js/icc_events.js b/apps/system/js/icc_events.js
index 88be40f..adf11cc 100644
--- a/apps/system/js/icc_events.js
+++ b/apps/system/js/icc_events.js
@@ -123,7 +123,8 @@ var icc_events = {
     function icc_events_handleBrowserTerminationEvent(message, evt) {
       DUMP(' STK Browser termination');
       this.downloadEvent(message, {
-        eventType: icc._iccManager.STK_EVENT_TYPE_BROWSER_TERMINATION
+        eventType: icc._iccManager.STK_EVENT_TYPE_BROWSER_TERMINATION,
+        terminationCause: icc._iccManager.STK_BROWSER_TERMINATION_CAUSE_USER
       });
   },
Flags: needinfo?(pengfei.huang.hz)
Hi Sean,
  Your patch works well. Pass the test.
  Thanks.
Flags: needinfo?(pengfei.huang.hz)
Comment on attachment 8560206 [details] [review]
[PullReq] weilonge:seanlee/STK/master/Bug1129831 to mozilla-b2g:master

Hello Fernando,

Here is my PR for this bug.
Could you help to review it?

Thank you.
Attachment #8560206 - Flags: review?(frsela)
blocking-b2g: 2.0M? → 2.0M+
Status: NEW → ASSIGNED
Assignee: nobody → selee
Comment on attachment 8560206 [details] [review]
[PullReq] weilonge:seanlee/STK/master/Bug1129831 to mozilla-b2g:master

r+ Thank you.

Could be great if we could detect a browser error, 404, 501, ... (STK_BROWSER_TERMINATION_CAUSE_ERROR) instead only user termination but not trivial now.
Attachment #8560206 - Flags: review?(frsela) → review+
Comment on attachment 8560206 [details] [review]
[PullReq] weilonge:seanlee/STK/master/Bug1129831 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):

[User impact] if declined:
The following spec is not implemented into our STK feature.
@ETSI TS 102 223 V11.3.0 (2014-06)
7.5.9.2 Structure of ENVELOPE (EVENT DOWNLOAD - Browser termination)
8.51 Browser termination cause

[Testing completed]:
Partner tested PASS in their LAB.

[Risk to taking this patch] (and alternatives if risky):
Only add one property to describe the cause of app termination.

[String changes made]:
None
Attachment #8560206 - Flags: approval-gaia-v2.2?
Attachment #8560206 - Flags: approval-gaia-v2.1?
Attachment #8560206 - Flags: approval-gaia-v2.2?
Attachment #8560206 - Flags: approval-gaia-v2.2+
Attachment #8560206 - Flags: approval-gaia-v2.1?
Attachment #8560206 - Flags: approval-gaia-v2.1+
You need to log in before you can comment on or make changes to this bug.