Closed Bug 1130013 Opened 5 years ago Closed 5 years ago

Add in web activity to settings to load app stats

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P2)

x86
macOS
defect

Tracking

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S7 (6mar)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: andy+bugzilla, Assigned: marshall)

References

Details

(Keywords: late-l10n)

Attachments

(4 files, 1 obsolete file)

Suggested activity is:

```
    new window.MozActivity({
        name: 'marketplace-search',
        data: {
            type: 'firefox-os-app-stats',
        }
    });
```

By re-using search we won't need to do a new marketplace build. The Marketplace will catch this activity to load the page created in bug 1129065.
Will we need to pass along any info from the device like locale or MNC/MCC so you can get the region?
Flags: needinfo?(amckay)
Nope, we detect all that in the Marketplace.
Flags: needinfo?(amckay)
(In reply to Andy McKay [:andym] from comment #2)
> Nope, we detect all that in the Marketplace.

OK, great!

Ravi/Geoff, do you know if any UX mockups or strings for integrating the WebActivity into the Privacy Settings were done?
Flags: needinfo?(rdandu)
Flags: needinfo?(gpiper)
Blocks: 1109426
This code needs to land as part of 2.2 to satisfy the user value requirement of making AppUsageMetrics (and therefore Monthly Active Users) opt-out.
blocking-b2g: --- → 2.2?
(In reply to Marshall Culpepper [:marshall_law] from comment #3)
> (In reply to Andy McKay [:andym] from comment #2)
> > Nope, we detect all that in the Marketplace.
> 
> OK, great!
> 
> Ravi/Geoff, do you know if any UX mockups or strings for integrating the
> WebActivity into the Privacy Settings were done?

I do not know of any...
Flags: needinfo?(gpiper)
Priority: -- → P2
No UX mockups or strings for integrating the WebActivity into the Privacy Settings were done. Please suggest a recommendation.
Flags: needinfo?(rdandu)
Please let me know which UX person was asked to work on this when the effort began, and I can follow up. Thanks!
Component: Statistics → Gaia::Settings
Product: Marketplace → Firefox OS
Version: Avenir → unspecified
Andy, is there an equivalent URL we can open instead of creating a MozActivity? It would be ideal if we could integrate the link in the privacy page rather than putting this in the Settings app.
Flags: needinfo?(amckay)
Proposed patch to add a link that launches a Marketplace search with app stats for region/locale
Attachment #8563696 - Flags: review?(arthur.chen)
Attachment #8563696 - Flags: feedback?(amckay)
Proposed screenshot (and string)
Attachment #8563702 - Flags: ui-review?(swilkes)
Attachment #8563702 - Flags: ui-review?(jelee)
Comment on attachment 8563696 [details] [review]
Add link in Settings app

Please check my comments in github, thanks.
Attachment #8563696 - Flags: review?(arthur.chen)
Comment on attachment 8563702 [details]
Proposed screenshot of 'Open App Statistics' Link

Hi Marshall,

Before the review... can you provide the complete UX flow of this feature? I need to know what's the purpose, how it works etc. Thank you!
Attachment #8563702 - Flags: ui-review?(jelee)
Jenny, let me know if this what you need:

Purpose:
We're providing a new section of the Marketplace that shows the most used applications (aka "App Stats") for a specific region/locale to our users, to provide them some tangible value in exchange for the AppUsageMetrics that we're collecting by default as part of FxOS 2.2.

We want to provide an direct link that opens this section of the Marketplace, on device.

Proposal:
Add a new link in the "Improve FirefoxOS" section of the Settings app, where users can currently enable or disable sharing usage data, to show them the benefits of having that usage data. When the link is clicked, the Marketplace app will be launched that shows this new content.

Caveat:
The implementation work for this new section of the Marketplace has not begun yet, and will happen after the client side code for v2.2 has landed. Until it's live, the link opens basically an empty Marketplace search.
Flags: needinfo?(jelee)
Thanks marshall, commented on github.
Flags: needinfo?(amckay)
Hi Marshall, 

Thanks for the answer! I just have two comments.
1) If the function is not ready, I would suggest we hold of putting the link as we don't want our users to see an empty page.

2) I think the title "Open app statistics" doesn't fully reflects the actual function (show most used apps info from Marketplace). let's needinfo Matej on this.

Hi Matej,
Can you review the string "Open app statistics" used described in comment 14? If needed, please provide a better title. Thanks!
Flags: needinfo?(jelee) → needinfo?(matej)
Comment on attachment 8563696 [details] [review]
Add link in Settings app

Comments on github.
Flags: needinfo?(matej)
Attachment #8563696 - Flags: feedback?(amckay) → feedback-
(In reply to Jenny Lee from comment #16)
> Hi Marshall, 
> 
> Thanks for the answer! I just have two comments.
> 1) If the function is not ready, I would suggest we hold of putting the link
> as we don't want our users to see an empty page.
> 
> 2) I think the title "Open app statistics" doesn't fully reflects the actual
> function (show most used apps info from Marketplace). let's needinfo Matej
> on this.
> 
> Hi Matej,
> Can you review the string "Open app statistics" used described in comment
> 14? If needed, please provide a better title. Thanks!

If it's really about the most used apps in a region, I would go with something like "Popular apps near you" to better convey the benefit to the user.

A more clinical version of the above could be "App usage by region" or "Most used apps by region."
Assignee: nobody → marshall
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8563702 [details]
Proposed screenshot of 'Open App Statistics' Link

Sorry for the delay. With CNY and UX folks in Paris the bugs are backing up a bit.
Attachment #8563702 - Flags: ui-review?(swilkes) → ui-review+
Target Milestone: --- → 2.2 S6 (20feb)
Marshall: any update on this?

Thanks
Hema
Flags: needinfo?(marshall)
Hey Hema, sorry for the delay.. I should have a new patch up soon
Flags: needinfo?(marshall)
Comment on attachment 8563693 [details] [review]
[gaia] marshall:bug1130013_appStatsLink > mozilla-b2g:master

Rebased patch that incorporates feedback from github. I changed the link text to 'App usage by region', let me know what you think. I've also verified that this is opening the new (placeholder) App Stats page on marketplace..
Attachment #8563693 - Flags: review?(arthur.chen)
Attachment #8563693 - Flags: feedback?(amckay)
Keywords: late-l10n
Comment on attachment 8563693 [details] [review]
[gaia] marshall:bug1130013_appStatsLink > mozilla-b2g:master

The patch is looking good to me. Please also request Jenny to review the latest UI, thanks.
Attachment #8563693 - Flags: review?(arthur.chen) → review+
Attached image app_usage_link.jpg
Jenny, Stephanie, this is an updated set of screenshots that includes the new placeholder page on Marketplace, and the new string change. Let me know what you think..
Attachment #8563702 - Attachment is obsolete: true
Attachment #8569966 - Flags: ui-review?(swilkes)
Attachment #8569966 - Flags: ui-review?(jelee)
Attachment #8563693 - Flags: feedback?(amckay) → feedback+
Comment on attachment 8569966 [details]
app_usage_link.jpg

Removing the flag for me; this one is for Jenny.
Attachment #8569966 - Flags: ui-review?(swilkes)
Comment on attachment 8569966 [details]
app_usage_link.jpg

Settings page looks good to me, thanks!
Attachment #8569966 - Flags: ui-review?(jelee) → ui-review+
master - https://github.com/mozilla-b2g/gaia/commit/23e53a0ae30fd4f69435bfc0a29379cc209e2274
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8572106 [details] [review]
[gaia] marshall:bug1130013_appStatsLink_v2.2 > mozilla-b2g:v2.2

This is a new link to the App usage by region ('App usage statistics') section of the Marketplace from the Settings app, providing user value for the opt-in of AppUsageMetrics

[Bug caused by] (feature/regressing bug #): Bug 1109422

[User impact] if declined: No way to get value from opt-in of app usage metrics collection

[Testing completed]: Tested on Flame with the placeholder site that is currently deployed on the marketplace (no app data has been collected there yet, as the server side code will happen after this)

[Risk to taking this patch] (and alternatives if risky): Telemetry server and Marketplace backends have not been integrated yet, so testing will not be complete until that happens..

[String changes made]: 1 new string for a new 'App usage by region' link under 'Settings > Improve B2G OS'
Attachment #8572106 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8572106 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Needs rebasing for v2.2 uplift.
Flags: needinfo?(marshall)
Target Milestone: 2.2 S6 (20feb) → 2.2 S7 (6mar)
I just pulled to rebase, but it looks like you already landed it?
Flags: needinfo?(marshall)
Sorry, Github got a bit confused and then I got even more confused by what it was telling me :P

v2.2: https://github.com/mozilla-b2g/gaia/commit/dfddae97ed9151897112d9637ab467f8c05352f1
You need to log in before you can comment on or make changes to this bug.