Closed Bug 1130298 Opened 5 years ago Closed 5 years ago

[Gaia] [Status Bar] [Clock] the clock echoes the wrong time while in a app

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

VERIFIED DUPLICATE of bug 1129835
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: Jamie_, Unassigned)

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150127140910

Steps to reproduce:

Flame
appid          	{3c2e2abc-06d4-11e1-ac3b-374f68613e61}
apptype      	b2g
vendor       	Mozilla
name         	B2G
version       	2.2.0.0-prerelease
appbuildid    	20150205162501
platformbuildid	20150205162501
platformversion	37.0a2
geckobuildid	20150205162501
geckoversion	37.0a2
changeset    	01446d5231ef
locale	                en-US
os             	B2G
hardware    	qcom
processor   	arm
compiler     	eabi
channel      	nightly-b2g37

I think this may be occurring on all build can someone please check for me

1.) look at time in the status bar
2.) open any app (settings in the date and time tab makes it a lot more obvious)
3.) observe the time in the status bar



Actual results:

Time in the status bar does not change at all. while in the home screen the time is still correct and when notifications pull down is open. While in app it stays the time it was when you entered it till you return to the home screen. You can swipe between apps and time still stays unchanged and pull down notification bar to see correct time, but when swiped back up the status bar is still unchanged.


Expected results:

time should be current no matter where on the phone you are if it is viewable
you said to need-info you if I was unsure of what to do with a bug or if I was not sure where to put it.
Flags: needinfo?(pmathur)
(moving to the system app which implements the status bar)
Component: Gaia::Clock → Gaia::System
to add this, I dont know if this problem is related to it, but it seems that sometimes the time also disappears randomly. It will reappear at times, but I have not found a reason that would cause it to reappear, both of these I have been searching through webIDE connected to the flame and cant seem to find a cause of this.
odd.  I thought it may have to do with : bug 1112706 ; though it's marked fix
QA will need to double check this and let dev know.  Please mark this a blocker if it is reproducible.

FYI: Guillaume.  needinfo is just to let you know that there might be something more to that bug.
Keywords: qawanted
(In reply to charja13 from comment #3)
> to add this, I dont know if this problem is related to it, but it seems that
> sometimes the time also disappears randomly. It will reappear at times, but
> I have not found a reason that would cause it to reappear, both of these I
> have been searching through webIDE connected to the flame and cant seem to
> find a cause of this.

the time disappears while in an app and you hit the screen power button, when you turn it back on the time is not there, after the status bar refreshes the time reappears and correctly and seems to be staying correct. after updating to build id 20150209002504 it does not repo 100 percent of the time but it still does, the part of the time disappearing after tuning screen off and on is still completely valid though.
I was able to reproduce this on Flame 3.0 and Flame 2.2

Steps:

1. Flash the phone.
2. Turn on cellular data on the FTE and keep tapping next to reach the homescreen.
3. Turn off "Set Automatically" on the "Date and Time" settings page.
4. Restart the phone using the power menu.
5. Once the homescreen boots back up, open the "Date and Time" settings page again.
6. Wait on the page for the time to change, paying close attention to the time shown on the page compared to the status bar time.

Actual Result:
The time on the "Date and Time" page will not be synced to the status bar time.

Environmental Variables:
Device: Flame 3.0 (Full Flash)(KK)(319mb)
BuildID: 20150209010211
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: 3436787a82d0
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38

Environmental Variables:
Device: Flame 2.2 (Full Flash)(KK)(319mb)
BuildID: 20150209002504
Gaia: e827781324cbde91d2434b388f5dead3303a85ee
Gecko: 0552759956d3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

------------------------------------------

I could not reproduce this issue on Flame 2.1

The time in the status bar always matched the time shown on the date and settings page.

Environmental Variables:
Device: Flame 2.1 (Full Flash)(KK)(319mb)
BuildID: 20150209001212
Gaia: 4a14bb118d55f3d15293c2ff55b7f29f9b0bfcdb
Gecko: 6cbe28d0bb8c
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: UNCONFIRMED → NEW
blocking-b2g: --- → 2.2?
Ever confirmed: true
QA Contact: jmercado
Whiteboard: [systemsfe]
Just a note here, this might be a dupe of bug 1129835, which landed after comment 6.
Can we re-test based on comment 7? (With the patch in bug 1129835)
Keywords: qawanted
blocking-b2g: 2.2? → 2.2+
Attached image wrong time.png
I have check against 2.2 nightly with build 20150210002516 this is still occurring as of today. it seems that it is getting closer, when it hits the two minutes off mark it corrects to current the is off again till the two minute mark.. eg 1:12 will stay 1:12 on status bar till its 1:14
Attached image fixed screenshot
On latest tinderbox central build this issue appears to be fixed. Following STR at comment 6, the clock at status bar now matches the time in Date & Time app.

See screenshot.

Tested on:
Device: Flame 3.0 Master (full flash, 319MB mem)
BuildID: 20150210130358
Gaia: 8c7865486a1b11076b849bbf8f7fccbaffbfafe7
Gecko: ee093ca70666
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
The regression window for this issue cannot be found.  I was able to reproduce this issue on the earliest central Flame KK build available, but was unable to reproduce this issue at all on Flame JB.  As this issue seems to be fixed with the patch in bug 1129835 per comment 10, I'm removing the window wanted tag.

Issue DOES reproduce (Flame KK):
Environmental Variables:
Device: Flame 2.2
BuildID: 20140904171737
Gaia: de59e0c3614dd0061881fe284e9f2d74fa0d1d5d
Gecko: 8703c1895505
Version: 35.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Issue does NOT reproduce (Flame JB):
Device: Flame 2.2
BuildID: 20140905031309
Gaia: 5765c62163bcb7fde5ebfd211881117de31a7c46
Gecko: dddbe46f3ceb
Version: 35.0a1 (2.2) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Marking this dupe based on comment 10, and the fact it still occurs on 2.2 which bug 1129835 has not been uplifted to yet. Let's make sure we verify this on 2.2 when bug 1129835 does get uplifted.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(pmathur)
Flags: needinfo?(gmarty)
Keywords: verifyme
Resolution: --- → DUPLICATE
Duplicate of bug: 1129835
Bug 1129835 had verified and according to comment 12, clear the "Verifyme"
Keywords: verifyme
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.