[RTL][FM Radio] The favorite station's scrollbar is not mirrored

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: jmitchell, Assigned: autra)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 attachments)

Description:
According to the BiDi (RTL) document https://mozilla.app.box.com/s/0y1amh4rwpp6brcxd1hk - page 16 "Scrollbars are now left-aligned, but still move vertically". 
The scrollbar in the FM radio app - which appears when adding more than a screen's worth of favorite stations, is not left-aligned and still appears on the right side of the screen. 

Repro Steps:
1) Update a Flame to 20150206010204
2) Launch FM Radio app
3) Save enough favorite stations to fill the screen (7+)
4) Scroll the favorite stations list

Actual:
Scrollbar not left aligned

Expected:
Scrollbar will be left aligned

Environmental Variables:
Device: Flame 3.0 (KK - Nightly - Full Flash)
Build ID: 20150206010204
Gaia: 94af4b42d2ace6c9f38f31de77240604fac68af1
Gecko: 7c5f187b65bf
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Repro frequency: 7/7
See attached: screenshot

-----------------------------------------------------------------------------

Also occurs in 2.2 

Device: Flame 2.2 (KK - Nightly - Full Flash)
Build ID: 20150206002505
Gaia: a52999ce7f783177deb17e267bf003a53e6fde06
Gecko: 01446d5231ef
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
feature-b2g: --- → 2.2+
Priority: -- → P2
I'm wondering if bug 1119057 would fix that ? Otherwise I  can look at this :-)
Flags: needinfo?(fabien)
This is not a duplicate. The scrollbar here is not even a root scrollbar.
Flags: needinfo?(fabien)
Assignee: nobody → augustin.trancart
Comment on attachment 8562840 [details] [review]
[gaia] autra:bug-1130644 > mozilla-b2g:master

Hey Pin Zhang,

Could you review this for me please? Thanks!
Attachment #8562840 - Flags: review?(pzhang)
Comment on attachment 8562840 [details] [review]
[gaia] autra:bug-1130644 > mozilla-b2g:master

r=me, thanks.
Attachment #8562840 - Flags: review?(pzhang) → review+
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
NI to myself to fix landing and request for 2.2
Flags: needinfo?(augustin.trancart)
Comment on attachment 8562840 [details] [review]
[gaia] autra:bug-1130644 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): not a regression
[User impact] if declined: low, only a scrollbar woud be on the wrong side
[Testing completed]: yes on flame 2.2
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Flags: needinfo?(augustin.trancart)
Attachment #8562840 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8562840 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Status: NEW → ASSIGNED
Please resolve bugs when they land on master. It potentially messes up uplift tracking otherwise.

v2.2: https://github.com/mozilla-b2g/gaia/commit/389542b71c89253c0d176d3b0bfb54e275c19bf1
Target Milestone: --- → 2.2 S6 (20feb)
Looks like this is fixed and landed on both master & 2.2. Augustin, please let me know if there's anything left to do here.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(augustin.trancart)
Resolution: --- → FIXED
It's all good then :-) Thanks!
Flags: needinfo?(augustin.trancart)
This issue is verified fixed on Flame Master and 2.2.

Result: Scroll bar appears on the left side of the screen.
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150225010244
Gaia: f6bfd854fe4746f21bc006eac145365e85f98808
Gecko: 0a8b3b67715a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0


Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150225002505
Gaia: ca64f2fe145909f31af266b1730874051ba76c78
Gecko: 16804008c29f
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15528/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.