[RTL][Settings]The back button displays as ">" in header when you select USIM卡应用 with a China SIM Card inserted.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Settings
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Sue, Assigned: arthurcc)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8561273 [details]
backbutton.png

[1.Description]:
According to comment 6 in Bug 1129830, this bug is filed.
[RTL][Settings]When you go to Settings ->  USIM卡应用 and select any option under USIM卡应用, the back button displays as ">" in header.
See attachment:backbutton.png

[2.Testing Steps]: 
Prerequisite: Insert a China SIM card
1. launch Settings -> USIM卡应用.
2. Select any options under USIM卡应用.

[3.Expected Result]: 
2. The back button should be displayed as "<" in header.

[4.Actual Result]: 
2. The back button displays as ">" in header.

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150208002500
Gaia Revision          e827781324cbde91d2434b388f5dead3303a85ee
Gaia Date              2015-02-06 20:54:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0552759956d3
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150208.035623
Firmware Date          Sun Feb  8 03:56:34 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
Summary: [RTL][Settings]The back button displays as ">" in header when you select USIM卡应用. → [RTL][Settings]The back button displays as ">" in header when you select USIM卡应用 with a China SIM Card inserted.
Assignee: nobody → arthur.chen
Status: NEW → ASSIGNED
feature-b2g: --- → 2.2+
Priority: -- → P2
Created attachment 8561913 [details] [review]
[PullReq] crh0716:1130965 to mozilla-b2g:master
Comment on attachment 8561913 [details] [review]
[PullReq] crh0716:1130965 to mozilla-b2g:master

EJ, could you help review this patch? Thanks. In this patch I simply replaced the three types of buttons with a handler function.
Attachment #8561913 - Flags: review?(ejchen)
Comment on attachment 8561913 [details] [review]
[PullReq] crh0716:1130965 to mozilla-b2g:master

Thanks Arthur ! I just left few comments on GitHub and please give it a check !

r+ by the way :)
Attachment #8561913 - Flags: review?(ejchen) → review+
Thanks, EJ!

master: 346df113f953e8baef04c7cca86cbbd03ae55ab3
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-master: --- → fixed
Resolution: --- → FIXED
Comment on attachment 8561913 [details] [review]
[PullReq] crh0716:1130965 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: The direction of the back arrow is incorrect.
[Testing completed]: Testing on the device. 
[Risk to taking this patch] (and alternatives if risky): Low. The patch simply switched to use gaia header.
[String changes made]: None
Attachment #8561913 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8561913 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/607a6c02afd3378297eef6c87f1899e60de7d402
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S6 (20feb)
(Reporter)

Comment 7

3 years ago
Created attachment 8564663 [details]
verify.png

This issue has been verified successfully on Flame 2.2/3.0
STR:
Prerequisite: Insert a China SIM card
1. launch Settings -> USIM卡应用.
2. Select any options under USIM卡应用.
**The back button displayed as "<" in header.
See attachment:verify.png
Rate:0/5

Flame 2.2 build:
Build ID               20150214002504
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/6de30e6bbc84
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150214.044811
Firmware Date          Sat Feb 14 04:48:22 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150214010227
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a7c177546ca0
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150214.043959
Firmware Date          Sat Feb 14 04:40:10 EST 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Depends on: 1136123
You need to log in before you can comment on or make changes to this bug.