After purchasing an app on desktop, force a refresh on the Reviews section to allow the user to rate the app

VERIFIED FIXED in 2015-02-24

Status

P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: krupa.mozbugs, Unassigned)

Tracking

2015-02-24
x86
Gonk (Firefox OS)
Points:
---

Details

(URL)

(Reporter)

Description

4 years ago
steps to reproduce:
0. Tester has not purchased the app being used in the test
1. Load https://marketplace-dev.allizom.org/app/compound-interest?src=search
2. Notice that the reviews section doesn't allow the user to add reviews.
3. Purchase the app on desktop



expected behavior:
After successful purchase, the reviews section show the 'Write a review' button


actual behavior:
After successful purchase, the reviews section doesn't update. The user needs to reload the page to see the changes.

Works fine on mobile.
Priority: -- → P3

Updated

4 years ago
Component: Payments/Refunds → Consumer Pages
I can't repro locally or on dev due to TRANS_REQUEST_FAILED. :andym, ideas?
Flags: needinfo?(amckay)
Assignee: nobody → charmston
Works for me: http://chuck.mn/2y362N3W322v
Assignee: charmston → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

4 years ago
Resolution: WORKSFORME → FIXED

Updated

4 years ago
Flags: needinfo?(amckay)
Target Milestone: --- → 2015-02-24

Comment 3

4 years ago
Verified as fixed on FF38(win 7) in MP-dev.
Postfix screencast http://screencast.com/t/2GJLpz2X
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.