[RTL][Download Manager]The download progress bar moves left to right.

RESOLVED DUPLICATE of bug 1131486

Status

defect
P1
normal
RESOLVED DUPLICATE of bug 1131486
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: mikehenrty)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

Reporter

Description

4 years ago
Posted image progressbar.png
[1.Description]:
[RTL][Download Manager]When you check the download progress in downloads list, the download progress bar moves from left to right.
See attachment:progressbar.png

[2.Testing Steps]: 
Prerequisite: Set system language as Arabic.
1. Launch Browser.
2. Download a large file from https://owd.tid.es/dm/.
3. Tap on the download start notification.

[3.Expected Result]: 
3. The download progress bar should move right to left.

[4.Actual Result]: 
3. The download progress bar moves left to right.

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150209002504
Gaia Revision          e827781324cbde91d2434b388f5dead3303a85ee
Gaia Date              2015-02-06 20:54:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0552759956d3
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.040038
Firmware Date          Mon Feb  9 04:00:51 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Updated

4 years ago
QA Whiteboard: [rtl-impact]
Whiteboard: [systemsfe]
Triage: P1
Priority: -- → P1
feature-b2g: --- → 2.2+
Ahmed, in bug 833401 it looks like we explicitly made the downloads list display in LTR mode even when the language is RTL [1]. Is this to spec, and if so is this bug invalid?

1.) https://github.com/mozilla-b2g/gaia/commit/c7048a521bc07f4e45664992ba46f4a196ddb746#diff-5cb1917b2f34c7e6ca11361714b980a7R266
Assignee: nobody → mhenretty
Flags: needinfo?(nefzaoui)
Oops, I mean to post the above comment in bug 1131486. Please ignore comment 2.
Flags: needinfo?(nefzaoui)
This will be fixed in bug 1131486, but let's make sure to get it verified once it lands.
Status: NEW → RESOLVED
Closed: 4 years ago
Keywords: verifyme
Resolution: --- → DUPLICATE
Duplicate of bug: 1131486
Reporter

Comment 5

4 years ago
Posted image verify.png
This issue has been verified successfull on Flame 2.2
STR:
Prerequisite: Set system language as Arabic.
1. Launch Browser.
2. Download a large file from https://owd.tid.es/dm/.
3. Tap on the download start notification.
**The download progress bar moves right to left.
See attachment:verify.png
Rate:0/5

Flame 2.2 build:
Build ID               20150225002505
Gaia Revision          ca64f2fe145909f31af266b1730874051ba76c78
Gaia Date              2015-02-24 22:06:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/16804008c29f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.041814
Firmware Date          Wed Feb 25 04:18:25 EST 2015
Bootloader             L1TC000118D0
Reporter

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Keywords: verifyme
Resolution: DUPLICATE → FIXED

Comment 6

4 years ago
This issue verified successfully on flame 2.2
Build ID               20150225162504
Gaia Revision          e4bf968d5a7366e7bdc58f0fdba28b32e864bdf7
Gaia Date              2015-02-25 18:39:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/da6ac51f5113
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Refer to video VIDEO0097_Compress.MP4
Status: VERIFIED → RESOLVED
Closed: 4 years ago4 years ago
QA Whiteboard: [rtl-impact][MGSEI-Triage+] → [rtl-impact]
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1131486
Reporter

Comment 7

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15744/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.